WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Photon not working at all?

[Resolved] Photon not working at all?

  • I’ve activated Photon on my site and expected the image URL’s to be re-written to point to WordPress caching server. Instead, it appears the images continue to be served from my local host. For example:

    Academy Award for Katana

    I don’t see any errors, and I tried a few basic troubleshooting steps like disabling all other plugins and switching to the Twenty Twelve theme to see if I was creating a conflict.

    Are there any other troubleshooting steps I should try?

    Thanks in advance,

    Rob

    http://wordpress.org/extend/plugins/jetpack/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    I had a look at your site, and you seem to be using relative paths for your URLs and image paths:

    <img src="/images/2013/02/beautiful-night-480x320.jpg" alt="beautiful-night" width="480" height="320" class="alignleft size-medium wp-image-2299">

    Could you try using absolute paths instead, and let me know if it helps?

    <img src="http://www.185vfx.com/images/2013/02/beautiful-night-480x320.jpg" alt="beautiful-night" width="480" height="320" class="alignleft size-medium wp-image-2299">

    Changing one of the images to use an absolute path worked perfectly. Unfortunately, I have a lot of posts and thousands of images all referenced with relative URL’s!

    Thanks for the quick response.

    Rob

    I found this plugin to help with the transition to absolute URLs:
    http://scott.yang.id.au/code/url-absolutifier/

    And modified it to work on the main content (in addition to feeds). Now photon is working exactly as expected.

    Thanks!

    Rob

    Oops, marking as resolved now.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Photon not working at all?’ is closed to new replies.