Support » Plugin: Jetpack by WordPress.com » photon not able to activate

  • Photon failed to activate. SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

    I get this info when I try to activate Photon

    and this when I try to activate downtime monitoring

    Monitor failed to activate. SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Contributor Ryan Cowles

    (@ryancowles)

    Hi there! The first thing to check is whether any other plugins on your site may have a conflict. Please check our Known Issues list here:
    Home

    You can also try to deactivate all plugins on your site, and see if that resolves the issue. If it does, then activate them one at a time to determine which is causing the conflict.

    If that doesn’t help, please rule out a theme conflict by temporarily changing your site’s theme to a default theme (such as Twenty Sixteen) and trying again.

    If you continue to experience trouble after trying the above, could you please provide me with a link to your site so I can take a look?

    ok now its working,
    updated JP manually

    I have had a few issues on my site and
    would like to check things out

    my sitemaps aren’t working on jetpack
    and
    what is kismet?

    Plugin Contributor Ryan Cowles

    (@ryancowles)

    ok now its working

    I’m glad to hear!

    my sitemaps aren’t working on jetpack

    Could you please let me know what exactly isn’t working? What steps result in the trouble?

    what is kismet?

    Akismet is our spam blocking service. You can read more about it here:
    https://akismet.com/how/

    I had the same issue and I ‘fixed it‘ disabling ‘disable-comments’ plugin.

    Kimbert, where you able to activate Photon?

    I’m getting this same error (SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data) when I try to activate pretty much anything.

    I was able to activate downtime monitoring via wordpress.com, but the corresponding settings for enabling Photon and JSON API, for example, are not available there as far as I can tell.

    If not, how can I debug this? I’m not sure if the GET response in my console is a clue:

    “body”:{“error”:”authorization_required”
    ,”message”:”An active access token must be used to retrieve notifications.”}}”

    thank you for any help you can provide!
    David

    @ryancowles

    I have not been able to get Jetpack to work correctly

    This is what I have found in my site on my sftp

    https://www.dropbox.com/s/95gxaxcr2lozv53/wp%20admin%20includes.doc?dl=0

    Now can you tell me what this is about and how to correct it.

    I get messages 403 errors when trying to connect to jetpack (Alex and Jeremy instructed me on how to look them up in the develop tools.

    tx for any help

    I have reinstalled the wpadmin/includes folder
    but am still getting the message error when trying to activate
    the security features and photon

    Here is the message i get in my browser console

    text/html
    Resource Type XHR
    Location
    Full URL https://galerieimbert.com/wp-json/jetpack/v4/module/protect/active
    Scheme https
    Host galerieimbert.com
    Path /wp-json/jetpack/v4/module/protect/active
    Filename active
    Initiator admin.js:9:28806
    Initiated
    Request & Response
    Method POST
    Cached No
    Status Forbidden
    Code 403
    Encoded 242 B
    Decoded 242 B
    Transferred 512 B
    Compressed Yes
    Compression 1.00×
    Request Data
    MIME Type application/json
    Data 15 B

    I have tried to connect another site to jetpack
    but am getting this message

    Failure to activate the recommended functions. SyntaxError….

    Échec de l’activation des fonctionnalités recommandées. SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

    I am wondering if this is because this site is a subdomain site???

    trois-echos dot com

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @kimbert As suggested in the other threads, it’s best if you send that information to my colleague Alex, who has been in touch with you via email about this and who will be able to help you.

    @aguadavid Could you please start your own thread, as per the Forum Welcome?
    https://wordpress.org/support/plugin/jetpack#new-post

    it would also help if you could let me know your site URL there, as well as the list of the other plugins you currently use.
    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.com/contact-support/

    Thank you!

    Jeremy I have sent 4 emails to Alex without an answer

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @kimbert If you contacted us, we’ll reply very soon. I’d recommend against sending multiple emails about the same problem, since it won’t push your ticket higher in our queue.

    ok Jeremy,

    I am just wondering if Alex got my email…

    @kimbert jetpack using rest api, I’ve got this issue when theme or plugin have a hook to disable rest api ( rest_url ). You could try remove those hook or add new hook to enable rest api.

    nicuidentitydesign

    (@nicuidentitydesign)

    I also had this issue I had jet pack installed on my blog that I host on my domain
    http://www.identitydesign.ro/wp
    I installed and worked very fine until I unistalled in order to verify some other features of other plug ins
    After that I choose to install that again and I get this message:
    Recommended features failed to activate. SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
    I checked other plug ins too and also reinstall wp did not managed until now to make that work

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘photon not able to activate’ is closed to new replies.