Support » Plugins and Hacks » Photon Image URL Errors After 2.1.2 Update.

Photon Image URL Errors After 2.1.2 Update.

  • After updating jetpack from version 2.1.1 to 2.1.2, Photon started butchering my image urls quite severly. Here is an example of my image urls when photon is disabled and enabled.

    Photon Disabled

    <img src="http://solidgoldsecurity.com.au/wp-content/uploads/Emergency-Kit-195093_113x96.png" alt="30 Piece Roadside Emergency Kit" width="113" height="96">

    Photon Enabled

    <img src="http:/i0.wp.com/solidgoldsecurity.com.au/wp-content/uploads/Emergency-Kit.png?resize=500%2C500-113x96.png?resize=500%2c500" alt="30 Piece Roadside Emergency Kit" width="113" height="96">

    The main problem with the photon src url is the lack of a forward slash “/” which you can see in 'http:/i0.wp.com'. Obviously its meant to be 'http://i0.wp.com'. The image re-sizing is also all over the place and not the correct 113×96 dimensions.

    What source code can I edit to at least get the http:// correct so the images will load.

    Site with issue – http://solidgoldsecurity.com.au/




Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jeremy Herve


    Could you try to disable all other plugins, one at a time, just to make sure the issue is not caused by a conflict with another plugin? I would recommend that you start with W3 Total Cache, and any image plugins that you may use on your site.

    Let me know if you find a conflict!

    I have verified this to be a photon issue. I first noticed after upgrading to 2.2. Disabling the photon plugin corrects the img src issue.


    I have recently updated both WordPress AND Jetpack to the latest versions, and had just the same fault with Jetpack. My images within posts fail to appear – I have 100% removed Jetpack until wordpress fix and let me know that this Massive error on their part is no longer an issue.

    Trying to be too clever too quickly – now one of the best plugins ever for WordPress is total poo!.

    PS to my last post – it is the Photon part of JetPack too please remove this rubbish or let users decide if they want it or not!

    Plugin Author Jeremy Herve


    @benwithem Could you point me to one of the posts where you experienced the issue, so I can have a look?

    Could you also let me know if you have any other image or gallery plugins active on your site, that may conflict with Photon?

    @webwales You can disable the Photon module in the Jetpack menu, as explained here:


    I don’t think that any of my plugins are image related.

    The thumbnails at the following link were affected: http://fbcranson.com/category/sermons/

    Here is source with photon:

    <img src="http:/i1.wp.com/fbcranson.com/wp-content/uploads/2012/09/Sermon-Graphic-July-29-2012.jpg?resize=376%2C443-188x188.jpg?resize=376%2c443" class='post-thumb' alt='Cursed Is The Ground' width='188' height='188' />

    And without:

    <img src="http://fbcranson.com/wp-content/uploads/2012/09/Sermon-Graphic-July-29-2012-27597_188x188.jpg" class='post-thumb' alt='Cursed Is The Ground' width='188' height='188' />

    Active theme: http://www.elegantthemes.com/gallery/modest/

    List of active plugins:
    Blubrry PowerPress
    BulletProof Security
    BWP Google XML Sitemaps
    Exclude Pages from Navigation
    Exploit Scanner
    Google Maps
    Jetpack by WordPress.com
    SEO Ultimate
    Sucuri Security – SiteCheck Malware Scanner
    Wordfence Security
    Yahoo! WebPlayer

    Plugin Author Jeremy Herve


    @benwithem @security Cameras Since both of you use themes from Elegant Themes, the problem might be similar to what others experienced and reported here:

    In this thread, Nick from Elegant Themes mentioned that he was working on a fix. You might want to get in touch with him about this, the additional details might help him.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Photon Image URL Errors After 2.1.2 Update.’ is closed to new replies.