Support » Plugin: Jetpack by WordPress.com » Photon image resize errors: Sorry, the parameters you provided were not valid

  • Resolved hungrycactus

    (@hungrycactus)


    Update 1: I was previously getting the errors as described below, but somehow those images are showing now. Is this a wp.com issue?

    Update 2: I found other images on my website that aren’t loading up correctly…can you guys load this image:
    https://i0.wp.com/www.hungrycactus.com/wp-content/uploads/yoroniku-13-of-19.jpg?resize=768%2C584

    I’m still getting a “Sorry, the parameters you provided were not valid”

    ~ ~ ~

    Hi I have an updated WP with Jetpack + Photon.
    in images loading, but now they are loading.

    Some images load up, but some return this error:
    Sorry, the parameters you provided were not valid

    OK:
    https://i0.wp.com/www.hungrycactus.com/wp-content/uploads/totorohouse-8-of-18.jpg?resize=768%2C1014

    NOT OK:
    https://i0.wp.com/www.hungrycactus.com/wp-content/uploads/totorohouse-9-of-18.jpg?resize=768%2C1014

    I have no idea why….the raw HTML post is below:

    <a href="http://www.hungrycactus.com/wp-content/uploads/totorohouse-8-of-18.jpg" rel="attachment wp-att-4108">
    <img class="aligncenter size-large wp-image-4108" src="http://www.hungrycactus.com/wp-content/uploads/totorohouse-8-of-18-776x1024.jpg" alt="totorohouse (8 of 18)" width="474" height="625" />
    </a> 
    
    <a href="http://www.hungrycactus.com/wp-content/uploads/totorohouse-9-of-18.jpg" rel="attachment wp-att-4109">
    <img class="aligncenter size-large wp-image-4109" src="http://www.hungrycactus.com/wp-content/uploads/totorohouse-9-of-18-776x1024.jpg" alt="totorohouse (9 of 18)" width="474" height="625" />
    </a>

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Tracy

    (@tmmbecker)

    @hungrycactus You’re seeing this intermittent behavior with Photon because your home page is image heavy. The image CDN isn’t able to load all of the images before the page finishes loading and that’s causing those broken image links that you’re seeing.

    You’ll see that when you load one of those images that gets that error, you can wait a few minutes and then it will work.

    You have a few options to fix this:

    1. Disable Photon. Doing this, though, would load all of these images from you server and slow the site down significantly. It would also make the site load pretty terrible for mobile visitors.
    2. Only display post excerpts on the home page. That would prevent all of the images for every post from loading every time.
    3. Disable Infinite Scroll. You can then set a certain number of posts to load, which would reduce the number of images having to load with the home page.

    Hope that helps!

    Hi Tracy — Thanks for the explanation and various options. I think I’ll choose to limit the posts.

    Much appreciated, and I really like WP + Jetpack!!!! 🙂

    What about:
    3. Enable Lazy Images?

    Would that also solve @hungrycactus‘s problem?

    hungrycactus

    (@hungrycactus)

    Robert — I did have lazy images enabled, but the problem with some images still come up. You can visit my site at http://www.hungrycactus.com/ and as you scroll down, not all the images will show up:

    https://photos.google.com/share/AF1QipNl6AtzkWEgNaKJwgRoKtcD8BnevC-2sDYyzkWqBzAuPFBe-RAyC0NWRC7F_vk6ng/photo/AF1QipP-51ydwcqKxrdOPhNbS8cGNoTCvENtWmfkOnwT?key=TC1pbEJRblJBY21IaHQ1NFBISXNONm1JOGdMVGh3

    Am I doing something wrong?

    I wish I had a good answer for you, but I don’t. I suggested trying Lazy Images because @tmmbecker implied that there might be a problem with performance or timing. Just now, I saw an error loading https://i2.wp.com/www.hungrycactus.com/wp-content/uploads/totorohouse-8-of-18.jpg?w=1040, but about a minute later the image loaded.

    Maybe the wp.com CDN used by Photon is throttling your requests. Have you tried using a different CDN, e.g. CloudFlare, instead of Photon/wp.com?

    Plugin Support Tracy

    (@tmmbecker)

    @trevellyan Thanks for chiming in here! The issues aren’t likely related to Lazy Images. The problem, in this case, is that the page is finished loading before Photon is able to load all of the images.

    This happens when there are too many images on the page. With new images, it also means that the image CDN isn’t immediately able to cache them when the post is published.

    When the image is loaded directly or the post is loaded again, the image is then added to the cache.

    Lazy Images does not rely on or work in conjunction with the image CDN, and it also doesn’t run on the direct link to the image itself, whether it be the CDN link or not.

    I hope this helps!

    There must be something I don’t understand about how Photon works. I assumed it was pull based, i.e. the first time a request is made to https://iN.wp.com/example.com/wp-content/uploads/image.jpg, the CDN would pull the image from //example.com/wp-content/uploads/image.jpg. That’s why I figured Lazy Images might help if there were a performance or throttling issue, because the requests would not all happen simultaneously.

    When you say “the page is finished loading before Photon is able to load all of the images”, it seems to imply that all the requests are sent simultaneously, regardless of whether Lazy Images is enabled.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Photon image resize errors: Sorry, the parameters you provided were not valid’ is closed to new replies.