WordPress.org

Forums

Jetpack by WordPress.com
[resolved] [closed] Photon Failure Messages in Header and Post (45 posts)

  1. Alduras
    Member
    Posted 2 years ago #

    After updating to the newest version I got this failure message within my website:

    Warning: array_key_exists(): The first argument should be either a string or an integer in /srv/http/domain.com/wp-content/plugins/jetpack/modules/photon.php on line 183 Warning: array_key_exists(): The first argument should be either a string or an integer in /srv/http/domain.com/wp-content/plugins/jetpack/modules/photon.php on line 183 Warning: array_key_exists(): The first argument should be either a string or an integer in /srv/http/domain.com/wp-content/plugins/jetpack/modules/photon.php on line 183
    lakajira - the gorean Network

    I have the failure on the top of the site and within the post with the image

    http://wordpress.org/extend/plugins/jetpack/

  2. Alduras
    Member
    Posted 2 years ago #

    P.S.
    With the version 2.0.2 I did not have that problem!

  3. jjfurn
    Member
    Posted 2 years ago #

    Have exactly the same problem!

  4. Isonomiablog
    Member
    Posted 2 years ago #

    Same problem for me at Isonomia.co.uk. I uninstalled Jetpack 2.04 and reinstalled 2.02, which resolved the issue. It's comforting to hear that it isn't just an oddity of the way my site is set up.

  5. Rev. Voodoo
    Volunteer Moderator
    Posted 2 years ago #

    Ditto for me

  6. ajkphotography
    Member
    Posted 2 years ago #

    Same here, I've disabled Photon until it's fixed.

  7. rossiback
    Member
    Posted 2 years ago #

    I don't know if its right, moved line 183 from Module/Photon.php } elseif ( isset( $size ) && array_key_exists( $size, $image_sizes ) && isset( $image_sizes[ $size ]['crop'] ) ) {

  8. BrianBY
    Member
    Posted 2 years ago #

    Same problem here. How to go about fixing it?

  9. Bruno Cunha
    Member
    Posted 2 years ago #

    Same problem here.
    http://www.brunocunha.com/blog/tecnologia/como-bloquear-propagandas-na-internet/

    Warning: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in /home/bcunha/public_html/blog/wp-content/plugins/jetpack/modules/photon.php on line 183

  10. jjfurn
    Member
    Posted 2 years ago #

    Also, can't insert media into post.

  11. misslawteedaw
    Member
    Posted 2 years ago #

    I have had the same problem, and now I had to deactivate Jetpack all together. On top of the error, it shrunk my photos.

  12. cactus_lime
    Member
    Posted 2 years ago #

    Same problem here!!!

    Warning: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in /storage/content/99/100399/vipblogg.se/public_html/wp-content/plugins/jetpack/modules/photon.php on line 183

  13. randellz
    Member
    Posted 2 years ago #

    im having the same issues on my site but only on a page template i've been coding.
    My issue is not site wide or at least that i can see, it only seems to appear on this particular page, and more so on the template i've created, i have turned of photon site wide and this has fixed the error, but im sure there is a fix or something ive not added to the code i should have.

    Does anyone know what triggers this error?

    i can show my code if that would help, im not the best coder so im guessing it's something ive done, as i was saying it's only appearing on a page ive created.

    <?php
    /*
    Template Name: MFRCode Sales Page Template
    */
    ?>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <title><?php bloginfo('name'); ?> - <?php the_title();?></title>
    <link href="<?php bloginfo('stylesheet_directory')?>/mfrcode-salespage.css" rel="stylesheet" type="text/css" />
    <meta http-equiv="Content-Language" content="en">
    <meta name="description" content="<?php bloginfo('description'); ?>">
     </head>
    <body>
    <div id="contenttop"></div>
    <div id="contentmid">
    <!----MFRCODE  Post php below-----!>
      <div id="contentcontainer">
    <div id="content" class="widecolumn">
     <?php if (have_posts()) : while (have_posts()) : the_post();?>
     <div class="post">
     <div class="entrytext">
      <?php the_content('<p class="serif">Read the rest of this page »</p>'); ?>
     </div>
     </div>
     <?php endwhile; endif; ?>
     <?php edit_post_link('Edit <---', '<p>', '</p>'); ?>
    </div>
    </div>
    <div id="text-bottom" align="center">
    <!----MFRCODE  Add your copyright info and site footer info below this line-----!>
    Copyright © <?php _e(date('Y')); ?> <a href="<?php echo home_url('/') ?>" title="<?php echo esc_attr(get_bloginfo('name', 'display')); ?>"><?php bloginfo('name'); ?></a> All Rights Reserved
    <br><font size="2"><?php bloginfo('description'); ?></font>
    <!----MFRCODE  DESIGN CREDIT MUST STAY INTACT UNEDITED OR TOUCHED IN ANYWAY OR YOUR SITE WILL RECIVE NO SUPPORT FROM US AND WILL BE CONSIDERED THEFT OF OUR WORK HTTP://RANDELLMONAGHAN.ME-----!>
    <br>
     <font size="1">WordPress Custom Sales Page Designed By: <a href="http://randellmonaghan.me" target="_blank">Randell Monaghan</a> | Proudly Powered By: <a href= "http://wordpress.org">WordPress</a></font>
      </div>
    </div>
    <div id="contentbottom"></div>
    </body>

    here's a link to the page also i'll turn photon on again just incase someone can help fix this.

    here is the troubled page

    thanks in advance everyone.

    p.s im a super messy coder so dont laugh lol.

  14. brownstone73
    Member
    Posted 2 years ago #

    Getting the same on my pages:

    Warning: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in /home/henry/public_html/wp-content/plugins/jetpack/modules/photon.php on line 183

    Any ideas pls.

  15. AGigante
    Member
    Posted 2 years ago #

    I have had the same problem...
    Deactivate the Photon Jetpack plugin would fix the issue.
    (click on "learn more" and the "deactivate" button will appear)

  16. eldan
    Member
    Posted 2 years ago #

    I am having the same issue, selectively on just 2 of the pages in my site. Deactivating Photon has fixed this for now, but it would be much better to see the issue resolved.

  17. 247creative
    Member
    Posted 2 years ago #

    I've also had this one crop up on a few pages on one particular site with Photon enabled.

    So far, the only solution for me was to disable Photon until this gets patched, which will hopefully be soon :)

    FWIW, the site I was having the trouble with has the Super Cache plug-in running, so I'm wondering if this might have something to do with the issue at all!

  18. gmfpanda
    Member
    Posted 2 years ago #

    Same problem here. I disabled photon and works fine now of course.

    I also have the super cache plugin. Tons of others too so who knows.

  19. 247creative
    Member
    Posted 2 years ago #

    I'm seriously starting to think caching is at the heart of this; the site I had problems with (out of a good number running Photon/Jetpack) was the one that had Super Cache installed in tandem. All the others I admin were fine as far as I can see!

  20. gmfpanda
    Member
    Posted 2 years ago #

    I forgot to mention I also had the shrinking image issues as well.

  21. jjfurn
    Member
    Posted 2 years ago #

    I did this and EVERYTHING WORKS FINE now.

    Try adding define('CONCATENATE_SCRIPTS', false ); to the bottom of your wp-config.php file (just before the require_once line).

  22. 247creative
    Member
    Posted 2 years ago #

    Interesting!

    Keeping Photon enabled on the site I was experiencing the problem with, and using define('CONCATENATE_SCRIPTS',false)l in wp-config.php seems to have fixed it for me too :)

  23. hijen
    Member
    Posted 2 years ago #

    Same problem: http://www.omnomnomnivore.com/2012/12/05/nothing-i-make-ever-looks-like-the-picture/

    Disabling photon didn't fix it either.
    :(

  24. jjfurn
    Member
    Posted 2 years ago #

    I did this and EVERYTHING WORKS FINE now.

    Try adding define('CONCATENATE_SCRIPTS', false ); to the bottom of your wp-config.php file (just before the require_once line).

  25. Darba_piedavajumi
    Member
    Posted 2 years ago #

    No error message after adding

    define('CONCATENATE_SCRIPTS', false );

    But images still appears smaller than I added to the website. Clicking on Images shows them full size but the embedded size is wrong.

  26. gmfpanda
    Member
    Posted 2 years ago #

    Same problem for me as Darba. Images are shrunk and aspect ratio isn't even kept. A page refresh fixes it for me but that doesn't help for my users.. :-/

  27. mcancell
    Member
    Posted 2 years ago #

    I am having the same problem "Warning: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in [redacted]../test/wp-content/plugins/jetpack/modules/photon.php on line 183".

    I am at a total standstill and don't know how to resolve. I hope we can get to the bottom of this soon.

    To see how problem appears, see here http://test.adverscan.com/products/addex-cooperative-postcards/

  28. jjfurn
    Member
    Posted 2 years ago #

    I did this and EVERYTHING WORKS FINE now.

    Try adding define('CONCATENATE_SCRIPTS', false ); to the bottom of your wp-config.php file (just before the require_once line).

    I didn't have the problem with the shrunken images, etc., but I didn't activate photon.

  29. mcancell
    Member
    Posted 2 years ago #

    My hosting provider was able to suppress the error messages, but could not do anything to actually correct the root of the problem. Now, although the "Warning" messages are gone, what we are left with are - shrunken images. So the core problem with the jetpack plugin is really not fixed.

  30. jjfurn
    Member
    Posted 2 years ago #

    Tell your hosting provider to go into the wp-config.php file and add the following line:

    define('CONCATENATE_SCRIPTS', false );

    near the bottom, just before the line that starts with require_once.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags