Support » Plugin: Jetpack by WordPress.com » Photon does not scale photos correctly on mobile

  • Original thread linked here where I talk about this issue.

    @designsimply‘s comments are here:

    @ultramarathoneer, I don’t have an Android phone, but I found a way to test Android using an emulator on browserstack.com and http://freedomrunusa.com and I could see the stretched images there: http://cl.ly/RS2q

    Can you try adding a CSS snippet like this to see if it helps?

    @media screen and (device-width: 320px) and (device-height: 640px) and (-webkit-device-pixel-ratio: 2) {
    	.flexslider,
    	#slider_wrapper {
    		height: 120px;
    	}
    }

    I got the media query part from here: http://cssmediaqueries.com/target/Samsung+Galaxy+S3.html

    Note that you might have to adjust “.flexslider .slides img” too, but try what I have above first to see if it works.

    I replied with:

    Thanks @designsimply. Unfortunately, that exact code is already in the css for the mobile version, although there is no mention of the .flexslider .slides img.

    I’ll dig some more to try to get it fixed, but the theme author already uses your suggested code for the responsive mobile theme. Appreciate the help…I’ll keep you posted.

    Another user responded directly after my post with the same issue, as did others in the thread that I jumped into.

    Starting a new thread here to see if we can get this resolved, as I’ve exhausted all my efforts to mess with the css as suggested.

    With the upgrade to 3.7 of wordpress, this issue still exists. If I disable the photon plugin, delete cache, the problem goes away.

    Thanks in advance!

    http://wordpress.org/plugins/jetpack/

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Photon does not scale photos correctly on mobile’ is closed to new replies.