Support » Themes and Templates » Photocrati gallery upload "http error"

  • No problem yesterday… problem today.
    No version changes of WP or Photocrati between last successful use and now.

    Can not upload images. “http error” included in red upload bar that turns red to show failed upload.

    Solutions tried:
    Everything that photocrati suggest. (plug-ins off. file names changed, Cache cleared. .htaccess code…)

    This does not seem to be a flash upload problem. I can still upload single images using WP flash upload without any problems.

    I am at a loss as to where else to look.

Viewing 14 replies - 1 through 14 (of 14 total)
  • I am unfortunately stuck between two worlds of “non-help”

    iPage (which has always provided me with excellent help) says that their scope of help stops short of being able to troubleshoot a problem I am having with photocrati/wp. (fair enough… but not helpful)

    Photocrati wants to blame iPage for not being up to snuff for WP and suggest that I just keep looking in the WP forum for help or just switch hosting companies. (grrr….)

    The problem is that I am not having any problem with WP and iPage. The issue seems to be Photocrati theme specific.

    If there is anyone out there that has had an “http error” message inside the upload status bar during an upload to a photocrati gallery… I would love to hear from you. (NOTE – I do not have any problem uploading images via WP flash up-loader… only with Photocrati upload.)

    The choice at the moment is to either dump photocrati or to dump iPage. Dumping photocrati seems like the less cumbersome option but I would rather just get it working again!

    I am having the same problem and got the same “canned” response from Photocrati. I’ll be watching the forum to see if you get any help.


    Complete un-install/re-install of WP did not solve the problem.

    Hi Guys,

    Same problem…seems to have started after 4.07 was installed…I too can also upload individual images but not any of the photocrati galleries. Also cleaned cache on both chrome and firefox and my provider says the problem is not on their end. I’m coming to the point where if the problem is not resolved, may have to go to another wordpress theme. Thanks!

    Below is a copy of the communications from photocrati. In my case I have tried all of there suggested fixes. I would be interested in knowing if any of this works for you. I get the impression that photocrati is stopping just short of saying “we are a BlueHost only theme”. I too have spent the afternoon looking at different theme options.

    It is worth noting that prior to the communications below I had, at their request, given photocrati full access to my site to look into the problem. Literally passwords to everything.

    As I mentioned before. I am stuck between a host that says it isn’t their problem and photocrati who says it isn’t their problem. I am inclined to believe that it is a photocrati problem but that they don’t want to address it.


    Hi Dominic.

    For IO errors, the first thing I would suggest is to log out of your site, clear your browser cache and cookies, do a full restart on your computer and also on your modem and see what happens. Typically IO errors are an issue with communication between your computer and your server.

    We’re currently looking into anything we can do within our Theme to help prevent these IO Errors. In the meantime, I would suggest doing some research in the forums for solutions, as it is a common error with WordPress and smaller server hosts. If switching hosts is an option, we suggest Recommended, especially BlueHost as our Theme and WordPress work very well there and have not seen yet this error appear on their servers.


    Photocrati Team Member

    Brian –

    You did not indicate whether or not you were able to replicate the problem.

    I am not sure if your response (basically just a repeat of what photocrati already has on its FAQ section) is based on anything you did to troubleshoot my issue.

    NOTE – I am not having any WP function problems with iPage. I am still able to upload images in WP. This is a wp/photocrati problem. Your suggestion that I cruse the WP forum for answers does not do me much good since the WP forum is for WP upload issues… which I am not having.

    I have an “http error” only when trying to upload images in photocrati. Is this the same as an IO error?

    All of you suggested solutions have been tried. No change.




    We are not able to replicate the same issue on our own sites. If we could, than it would be an issue with our Theme which we would need to correct right away. This is an issue related to an IO Error (HTTP & IO are very similar errors), which is flash related. The root of the issue is with communication between your computer and your server. Unless we can replicate the issue on our own test sites, unfortunately we cannot produce a solution for you. This is why we suggest searching the WordPress forums for users who have experienced the same error. From what we’ve seen, iPage & Powweb seem to be some of the more popular server hosts who produce HTTP and IO errors. As mentioned, BlueHost, one of the server hosts we test our Theme almost daily on – we have yet to see that error on their servers using WordPress + the Photocrati Theme.



    Photocrati Team Member

    Basically the same response I got.

    You can test this quite easily.

    Just switch your theme to twentyten. (Since elements of your former theme may still remain, it would probably be best to remove it for now, perhaps move it to another folder other than the themes folder while you test).

    Then watch how your site works for the next day or two.

    From what I have been able to tell, photocrati seems to run some very nice-looking, but very heavy, themes.


    I started having the same problem getting an “HTTP Error” when I attempt to upload images. I did the troubleshooting they reccomended on the site then I contacted my host. My host upped my mb limit but said there wasn’t any problem on their end and it had to be the third party software ie WordPress.

    I then contacted Photocrati about the issue. Brian got back very quickly and I too gave them all my passwords etc and they have been working on the issue. But due to the new version coming out its not top priority.

    I was told to get the last update of Photocrati, which I did, but it didn’t work either. I was told the easiest way to solve it was to switch to Blue Host but I have just renewed my host who I’ve been with for 6 years with no problem. I was told that they never had this issue on Blue Host and that other people have solved their issue by using BH. I don’t want/can’t switch hosts as so this doesn’t help.

    So now I’m just waiting for somebody to come up with a solution but in the mean time I’m shooting a wedding on Saturday so I need a way to upload photos so I can sell them. I hadn’t heard of WordPress Flash Uploader that you mention so I’m going to look into that. I don’t really have time to switch to another theme right now so I’m a bit concerned.

    I hope someone comes up with a solution because nothing I’ve tried works.

    Photocrati contacted me and informed me that their developers had found a fix.

    I had to give them all of my login info again (wordpress, host, etc.) so that they could get in and make the fix.

    It is working for me again but I have no idea what they did to get it working.

    This tells me that it is a case by case fix which has me a bit worried that future updates will equal continued problems. We shall see.

    Best of luck to everyone.

    Same canned response here. I found this works on a Dell/Windows but not on a Mac. In this day and age, to have issues like this for a theme that costs $79 is uncalled for, really. Surprised to find this hasn’t been fixed and they’re still selling the theme.

    same canned response but works on my mac. problem solved from my end. we’ll see how their new big update manages….

    After having the same frustrating experience I found a work around solution until someone fixes it.

    Install NextGen gallery plugin.
    Upload your photos into a next gen album.
    Create new photocrati album.
    Import photos from the next gen album.

    I hope there’s an official fix soon but this worked well for me.

    Issue fixed after checking with web hosting setting.

    “Found the problem, basically the wordpress plugin triggered the mod security.

    Access denied with code 406 (phase 2). Pattern match “^Shockwave Flash” at REQUEST_HEADERS:User-Agent. [file “/usr/local/apache/conf/modsec2.user.conf”] [line “203”]

    I have bypass the shockwave security.”

    So you may check with your hosting provider to change that setting.

    Hope it work for you!

    I also came across this problem – when I checked my apache logs, there were some PHP errors about running out of memory, so I reduced the size of the images (and subsequent files) and they upload ok. In a nutshell, check your server logs for odd messages at upload time.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Photocrati gallery upload "http error"’ is closed to new replies.