WordPress.org

Support

Support » Plugins and Hacks » Photo Upload Not Working

Photo Upload Not Working

  • Whenever I try to upload a photo I get this error “There is something wrong with the file you tried to upload. Try another.”

    I first tried a jpg 300×300 pixels, then I tried downsizing it to 200×200. I also tried a 100×100 png file.

    I thought maybe NextGen gallery was interfering, but I deactivated it and still got the same error.

    Any clues?

    http://wordpress.org/extend/plugins/participants-database/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author xnau webdesign
    Participant

    @xnau

    This is most likely a problem with a case mismatch in the uploads directory. Is your site on a Windows server? You may not know, but it doesn’t matter. Windows servers use case-sensitive paths and the far more common Apache servers don’t. The first thing to try is to make sure the path to the uploads directory (as defined in the plugin settings) has the same case as the path as defined on the web server. You would probably be able to know this by looking at the path in a FTP client.

    Thanks for pointing this out…not a problem many users will run into, but I do have a code fix for this. If you cannot get it working by fixing the uploads path setting, let me know and I’ll provide you with the code fix.

    I haven’t been able to find any case differences or miss-spelled directories. I tried retyping everything, too, but no luck. still getting the same error.

    Plugin Author xnau webdesign
    Participant

    @xnau

    OK, well the fix for this requires an edit to the file participants-database.php on line 2161, you’ll find:

    if (!is_uploaded_file($file['tmp_name'])) {

    Change this to:

    if (!is_uploaded_file(realpath($file['tmp_name']))) {

    I can’t test this, so I’d like to hear if it works for you or not.

    Thanks, I’ll give it a shot.

    Still doing the same thing.

    This may be bogus, but in the box where I select a file name to upload, the only thing visible is the file name, and no path. Normal?

    Is there some error reporting I can turn on to help you out?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Photo Upload Not Working’ is closed to new replies.