Support » Fixing WordPress » Photo upload error

  • Hello, I have a problem with photos upload. After 1 h fresh install of WordPress 4.4.2 I receive an error when I try to upload photos on my articles. If I go to updates and I do reinstall the upload start working again for another hour… and after the same problem. I mention that the photo’s are uploading but not showing first time. They show after some time. My error is :

    An error occurred in the upload. Please try again later.

    My hosting provider told me that they found a error log :

    [Sat Feb 13 12:30:24 2016] [error] [client 37.251.165.12] Premature end of script headers: index.php, referer: http://hyperflash.ro/wp-admin/upload.php

Viewing 12 replies - 1 through 12 (of 12 total)
  • Somebody please?

    Hey JustIrinel,

    It looks more like a host’s issue.
    http://www.liquidweb.com/kb/apache-error-premature-end-of-script-headers/

    Regards,
    Mayank

    Hmm @mayank but how is explained the fact that if I make a re-install using Update section, I can upload again for a limited time? That’s strange.

    @justirinel: let’s troubleshoot 🙂

    some points to keep in mind…

    1. Are you on a shared host? or VPS?
    2. Which version of PHP are you using?
    3. Have you tried to disable all the plugins?
    4. I believe you’re using Linux based hosting
    5. Can you confirm from host if they changed the server environment recently i.e. if they did any update of Apache or PHP
    6. Are you using Suhosin.
    7. Please see this post : https://wordpress.org/support/topic/premature-end-of-script-headers-indexphp?replies=20 What it suggests is that it could be a memory issue as well. However, do go through all of it.

    Point being, your host should be able to help in this case and is sort of beyond our support scope.

    @mayank

    1. Shared
    2. 5.4
    3. Yes… no change
    4. Yes
    5. I changed hosting from other provider. I moved wordpress to another provider.
    6. I dont know.

    My host telled me that they didnt find any log to investigate the problem.

    @justirinel: I suggest sharing that above mentioned URL with your host and the link to this URL as well or you may want to share my chats with them. I’m sure they’ll be able to figure out something.

    As far as I can see –

    1. it may be because of suhosin. only host will be able to confirm
    2. php 5.4 works fine with WordPress.
    3. Memory also looks like an issue.

    What’s wrong with Suhosin @mayank ?

    My hosting package specs are :
    2GB RAM
    2Ghz CPU
    Max 30 Entry processes
    INODES 100000
    IOPS 1024
    Memory_limit 128MB
    Max execution time 30s
    Disabled functions

    symlink, apache_child_terminate, apache_setenv, define_syslog_variables, es-
    capeshellarg, escapeshellcmd, eval, exec, fp, fput, ftp_connect, ftp_exec, ftp_get,
    ftp_login, ftp_nb_fput, ftp_put, ftp_raw, ftp_rawlist, highlight_file, ini_alter, ini_
    get_all, ini_restore, inject_code, mysql_pconnect, openlog, passthru, phpAds_re-
    moteInfo, phpAds_XmlRpc, phpAds_xmlrpcDecode, phpAds_xmlrpcEncode,
    popen, posix_getpwuid, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid,
    posix_setuid, posix_setuid, posix_uname, proc_close, proc_get_status, proc_
    nice, proc_open, proc_terminate, syslog, xmlrpc_entity_decode

    My hosting provider link: https://www.xservers.ro/

    1. are you on an unmanaged VPS? because specific specs can’t be shared in a shared environment. And even if they’ll share the specs – we can’t figure out that how much your website was assigned.

    2. Suhosin is for security and it tends to mess up. A quick google search about the issue suggested that a lot of people were facing issue because of this. Even the first link suggested that suhosin could be an issue.

    My hosting provider is one of best in my country, it offers shared packages with Cloudlinux to give a fixed amount of resources to each packages. What I need to ask them about suhosin ?

    1. Agreed but if they’re the best then why aren’t they able to help you?
    2. I can also make a statement like above: “WordPress is best, I don’t face this issue on my hosting.” So, is my hosting better than your country’s best? You be the judge.
    3. You shifted hosting and then only you faced the issue..

    i’m trying to help you zero down the problem when it should be the host that should be working with you on this matter. it’s clearly a hosting issue.

    Have you shared this URL & the URL that I gave at the first place to your webhost?

    Tell me what I need to tell them because I need to translate please 🙂 , I need to ask if suhosin is active ?

    I would say please suggest them to use google translate. For both the URLs that way it’ll be much more easier.

    Since I can’t login to FTP & WP – I can only give you suggestions. And all these links that i’ve shared have lot of steps that you can take and see if that solves the problem… or not.

    https://wordpress.org/support/topic/premature-end-of-script-headers-indexphp?replies=20 go to this link and try and follow what Daisyhead tried and see if any of that works.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Photo upload error’ is closed to new replies.