WordPress.org

Forums

SSH SFTP Updater Support
Persistent Login Screen (12 posts)

  1. tawshmcd
    Member
    Posted 1 year ago #

    After successfully installing this plugin, I am able to activate it.

    My problem occurs when I try to activate 'any' other plugin or when I try to do let's say an update on any plugin.

    When I try to activate a plugin, I'm being prompted to enter in my credentials. I enter in the correct credentials (which are 100% accurate because I am able to login to both Dreamweaver and Transmit with these) yet I continue to receive the following error message:

    --
    There was an error connecting to the server, Please verify the settings are correct.

    --

    To make matters worse, I am stuck on this page. I can no longer access the main plugins, appearance, comments, tools, users, or settings panels. The URL remains stuck on this string "www.mydomainhere.com/wp-admin/themes.php?page=all-in-one-event-calendar-install-themes" (if I chose another plugin to activate, the string will be stuck on that).

    I've had to dive into Transmit and delete all my plugins manually over an FTP client in order to get the login screen to disappear.

    I also wanted to point out, that I'm working over a VPN. Does this effect anything?

    Do I need to have anything installed on the server for this to work?

    I have "phpseclib" in the "ssh-sftp-updater-support". Is there any permissions I need to set on the "ssh-sftp-updater-support" folder (or its subfolder, "phpseclib")?

  2. TerraFrost
    Member
    Plugin Author

    Posted 1 year ago #

    I apologize for the tardyness of this response.

    Anyway...

    In class-wp-filesystem-ssh2.php can you find and uncomment out this line?:

    //define('NET_SFTP_LOGGING', NET_SFTP_LOG_REALTIME);

    If you could post the output after that that'd be helpful.

    In lieu of those... it's possible the server is just blocking requests from localhost or something. If that's what was going on the logs wouldn't be of too much use but the logs could provide insight if there was something else at play.

    Thanks!

  3. tawshmcd
    Member
    Posted 1 year ago #

    Thanks for your response.

    I've uncommented that line and re-tested.

    I'm still getting the same error message.

  4. TerraFrost
    Member
    Plugin Author

    Posted 1 year ago #

    Assuming that the output didn't change when you did that... open class-wp-filesystem-ssh2.php and find this line:

    if ( ! $this->link ) {
    			$this->errors->add('connect', sprintf(__('Failed to connect to SSH2 Server %1$s:%2$s'), $this->options['hostname'], $this->options['port']));
    			return false;
    		}

    Replace it with this:

    if ( ! $this->link ) {
    			$this->errors->add('connect', sprintf(__('Failed to connect to SSH2 Server %1$s:%2$s'), $this->options['hostname'], $this->options['port']));
                            exit('THIS FAR')
    			return false;
    		}

    And tell me what happens.

    I'm still getting the same error message.

    The change I had you made wasn't intended to fix the issue so much as to provide me info with which to diagnose it.

  5. tawshmcd
    Member
    Posted 1 year ago #

    Dreamweaver is telling me that there is a syntax error with that line of code.

    I replaced it anyways, and now I'm getting a blank screen in WordPress when I enter in my login credentials.

    Still no fix. :(

  6. TerraFrost
    Member
    Plugin Author

    Posted 1 year ago #

    I left off the semi-colon for exit('THIS FAR'). Try this:

    if ( ! $this->link ) {
    			$this->errors->add('connect', sprintf(__('Failed to connect to SSH2 Server %1$s:%2$s'), $this->options['hostname'], $this->options['port']));
                            exit('THIS FAR');
    			return false;
    		}

    (I'd edit my orig post but it doesn't appear that I can)

    Still no fix. :(

    It's not supposed to fix it so much as provide me with more diagnostic information.

  7. tawshmcd
    Member
    Posted 1 year ago #

    I updated my code with the semi-colon.

  8. TerraFrost
    Member
    Plugin Author

    Posted 1 year ago #

    So what happened? Can you give me a screenshot of the page you're seeing when you try to login with this plugin?

    Thanks!

  9. tawshmcd
    Member
    Posted 1 year ago #

    Ahh, I'm still receiving the same error from the beginning with the screens being stuck on the credential page.

    --
    There was an error connecting to the server, Please verify the settings are correct.
    --

    This editor doesn't allow me to upload the screenshot!

    Thanks!

  10. TerraFrost
    Member
    Plugin Author

    Posted 1 year ago #

    It's not saying anything else?

    You can post a screenshot here:

    http://imgur.com/

    Thanks!

  11. tawshmcd
    Member
    Posted 1 year ago #

  12. TerraFrost
    Member
    Plugin Author

    Posted 1 year ago #

    Can you post a screenshot of the "There was an error connecting to the server, Please verify the settings are correct." error that you're getting?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SSH SFTP Updater Support
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic