Support » Fixing WordPress » persistent error report related to autosave

  • Resolved ponderman


    Accessing my website persistently yields this error report on top of the display:
    Warning: call_user_func_array() []: First argument is expected to be a valid callback, ‘disableAutoSave’ was given in/home/newshore/public_html/wp-includes/plugin.php on line 395

    It does not matter to me whether I have an active or deactivated autosave. How can I make this error go away?

    I see nothing that looks unusual in either functions.php, wp-config.php or the named plugin.php. Any suggestions? I have tried for over three hours now without success, and restoring from a previous backup did not rectify the problem either

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator James Huff


    Halfelf Minion 🚀

    Try decativating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Default theme (WordPress 2.9) or the Twenty Ten theme (WordPress 3.0) to rule-out a theme-specific issue (theme function files can interfere with admin panel tasks).

    will try rightaway – thank for the pointers —

    deactivating plugin did not help. The same error msg appeared in the admin panel.

    Switsched to default theme – the above error had disappeared, but I received a new error msg:

    has_post_thumbnail() in /home/newshore/public_html/wp-content/themes/twentyten/header.php on line 71

    this is entirely new. I suspect that this error is due to having installed the menubar plugin which required an entry in the header. With that plugin removed – this is the likely reason.

    But now I have something to work with. If I flush it out, I will make a note of it here. But your comments certainly added a ray of hope —– Many thanks

    Moderator James Huff


    Halfelf Minion 🚀

    You’re welcome! It definitely sounds like a theme problem at least, or maybe a combination plugin/theme problem. The next thing you might want to do is upload a fresh copy of the theme (download and save your current copy as a backup) and see if that causes any trouble.

    Getting to be a bit gun-shy. Activating the plugins (had only three) butchered the 2010 default theme – only showed the blogline and an error msg about the header. Will try to first deal with the header error – use the 2010 theme to display properly, perhaps removing the call for the menubar will help.
    But all said and done, something about the autosave is the primary culprit. Any idea what callback is expected in the line 395 error msg?

    Moderator James Huff


    Halfelf Minion 🚀

    I did some quick research on the error, and while I have found no definitive solution, it does appear to be related to a particular plugin each time, though everyone seemed to mention a different plugin. In each instance, deactivating then reactivating all plugins individually revealed the particular one causing the problem. After that, some replaced the plugin in question with a fresh copy of the plugin’s file or found an alternative plugin.

    I’d start with the Default theme active and all plugins disabled, then start activating plugins individually. If you can survive with the Default theme and all plugins active, then the problem must be specific to your theme.

    Trying your suggestion and other ideas, I solved the problem. The major mistake I made was to copy the entire 2010 theme’s function.php to my child theme directory. It was my understanding that the child’s function.php will be read first and “override” the function.php of the 2010 theme itself. That is only partially true. I wanted to eliminate the header image alltogether, i.e. declare its width and height to be zero, and did so.

    In the end, I only kept the part of the function.php related to the header image in my child theme’s function.php which was commented with a start/end notation for the hedare modification “business” (the words used in that file). That removed all error messages – all is back to ‘normal’ now, and the menubar plugin is active and fine.
    Thank you much for your help in all of this – it took much time to figure out. I will now mark the issue as resolved.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘persistent error report related to autosave’ is closed to new replies.