Support » Plugin: W3 Total Cache » persistent error about _wc_session_

  • Resolved SRD75

    (@srd75)



    Hi,

    I’m running a MU WordPress install.

    In the main site’s dashboard (example.com/wp-admin), I receive the error:

    In order for database caching to work with WooCommerce you must add _wc_session_ to the “Ignored Query Strings” option in W3 Total Cache settings here.

    If I go to example.com/wp-admin/network/admin.php?page=w3tc_dbcache I see that _wc_session_ is ignored already.

    Yet the error in example.com/wp-admin persists.

    Regards,
    Steve.

    https://wordpress.org/plugins/w3-total-cache/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Ashok

    (@bappidgreat)

    Hello SRD75

    Is either of the plugin is not network activate? It seems you have W3TC network activated, but what’s about woocommerce?

    Have a good day!

    Cheers
    Ash

    The plugin is network activated.

    Hullo?

    Ashok

    (@bappidgreat)

    Hi there

    I can’t replicate this notice in my network. Would you please double check in dbcache settings page, the ignored string is _wp_session_ or _wc_session_? By default, _wp_session_ should be there, not _wc_session_.

    Have a good day!

    Cheers
    Ash

    Hi, the error is:

    In order for database caching to work with WooCommerce you must add _wc_session_ to the “Ignored Query Strings” option in W3 Total Cache settings here.

    I re-added _wc_session_ to the “Ignored Query Strings” option (it has not saved from the last attempt), and the issue is now resolved.

    Thanks.

    Ashok

    (@bappidgreat)

    Great, glad to see it resolved 🙂

    Unfortunately I have the same issue 🙁 (latest release of W3TC)

    I have the following settings:

    Ignored query stems:

    gdsr_
    wp_rg_
    _wp_session_

    Yet I get:

    In order for database caching to work with WooCommerce you must add _wc_session_ to the “Ignored Query Strings” option in W3 Total Cache settings here.

    Also, there is a small typo there I believe 🙂

    “Ignored Query Strings”

    Should read:

    “Ignored query stems:”

    …as there is no such thing as “Ignored Query Strings” on that page =)

    Any suggestions as to what to try to get that error to go away? I tried removing it and then re-adding (as the other guy said worked for him), but still it persists 🙁

    Cheers

    Andy

    • This reply was modified 1 year, 6 months ago by  .

    Hi Andy,

    You wrote you have added: _wp_session_ but you need to add: _wc_session_

    Cheers,
    Steve

    haha oops – now I feel stupid! That fixed it, thanks!

    Although, there is still the typo that needs fixing up to avoid confusion for others 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘persistent error about _wc_session_’ is closed to new replies.