Support » Fixing WordPress » Permissions Problem, can't install plugins.

  • Hello,

    I just got my WP blog moved to new powerful server, then I tried to install any plugin it asked for FTP permissions I entered the details in config.php file (I googled it).. the problem got solved.

    But now when I try to install plugins, they give permission error such as, I received CHMOD 777 error while installing WP Total Cache. I think something messed up while changing webhost. I checked and matched the permissions from other WordPress blog they looked same. Then, why do I have to change them? Is there anything wrong with sever configurations?

    PS: I don’t wanna set permissions to 777 to every folder in root, it will cause security issues.

Viewing 6 replies - 1 through 6 (of 6 total)
  • There are times when you will have to change permissions to upload as in this case caching. Once it is enabled change back your files to their original permissions.You are correct don’t leave files permanently with chmod 777.
    It is quite possible that your host has nailed down the files for security, which unfortunately because of some unsavoury characters is warranted.

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.


    If I change the file permissions, it would temporarily work but when I need to install another plugin I have to change it again.

    Is there any other solution? I have full control over my server of WHM/Cpanel, when I was on my shared hosting, I could install every plugin smoothly without issues.

    Issue#2: The XML sitemap generator plugin is not functioning proper. It is not rebuilding sitemap automatically whenever I publish a post.

    Its a server configuration issue – not a WordPress one, I’m afraid.

    How do I fix it?

    Check if you have administrator access to your server.

    If you want to install W3 Total Cache you may want to read item 4. in my article which points to a video.

    Since you have moved to a more powerful hosting services they may have more and better security and firewall. You may want to inform your host tech support that you have a CHMOD 777 error. If they have set up the blocks (due to an unbelievable of hacking going on in the internet), they can modify it for your requirements.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Permissions Problem, can't install plugins.’ is closed to new replies.