Support » Plugin: Code Snippets » Permissions problem after install

  • Resolved Shebo


    I was so happy that I could finally install your plugin and play with it, I’ve liked it from the moment I’ve read about it. But then I bumped into a brick wall 🙂

    Every time I installed the plugin, the ‘manage’ link is leading me into the right page, but only the error “You do not have sufficient permissions to access this page.” is appearing.
    Also, no table is created in the wordpress DB (needles to say that other plugins worked properly and even add their tables to my DB with no problems).

    I’ve tried it all, god’s honest. I’ve installed fresh wp installs, with and without custom db prefix, locally and on 3 different servers. I went and tried to install the plugin on some up-and-running wp installations I have, some with versions 3.4, 3.4.2 and eve 3.3.2. Nada.

    Tried to screw with htaccess files, wp-config.php, file permissions, apache permissions and more, and again, Nada.

    Do you heard about this problem before? Do you have an idea how can it be solved? I would really much like to work with your plugin.

    Thank you very much,

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Shea Bunge


    Code Snippets uses custom capabilities for accessing the admin pages. It seems that these capabilities are not being applied on installing the plugin. I’ll soon release version 1.6.1 which will fix this bug.

    Thanks for drawing my attention to this problem, and for taking the time to test it thoroughly. You’ve been a big help! 😀

    Plugin Author Shea Bunge


    The reason the database tables were not being created is because, from version 1.6 onward, the tables are only created when visiting a snippet admin page. This is to prevent creating unnecessary empty snippet tables when Network Activated on multisite networks, where the Code Snippets plugin may not be used on every site.

    That’s great man! Thank you very much, I’ve installed it now (the 1.6.1 ver.) and finally made it to the snippets management screen without any problems.

    When I did it with “WP_DEBUG” mode ON, after the activation I got the error

    WordPress database error: [Table ‘wptry.wp_snippets’ doesn’t exist]
    SELECT code FROM wp_snippets WHERE active=1;

    But no wordpress or php fatal errors, and after I added the first snippet the table was created and the debugging error was gone.

    Again, thank you for the attention and the quick response, and of course for plugin itself! I’m sure it’s gonna be a big help for me from now on.

    Have a good one,

    Plugin Author Shea Bunge


    I’m glad it’s working now! I’ll have a look into the error you received; it should be fixed in the next version.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Permissions problem after install’ is closed to new replies.