Support » Plugin: Optimum Gravatar Cache » ** Permissions (OCTAL)

  • ResolvedPlugin Contributor Will Stocks

    (@willstockstech)


    Hi Miguel,
    When I hit “Save Changes” in the OGC admin panel, I get an error come up:

    Optimum Gravatar Cache
    Could not apply the permissions ‘0775’ to the ‘server-path/wp-content/uploads/optimum-gravatar-cache/avatar/’ directory.

    I logged in to my FTP, navigated to the folder and 0755 is the permissions already set on the folder. I reapplied the permissions manually and recursed into all files and folders (just to check) and hit “Save” again – the same error popped up.

    I’m not sure what this is or isn’t doing?

    Gravatars seem to be generating correctly though!

    OGC v1.4.4

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Will Stocks

    (@willstockstech)

    Also, I will spin this off into a separate topic – but mentioning it while I’m here:

    the OGC database table that gets created appears to be considered as orphaned by a lot of DB plugins (main one I use is WP-Optimize). If you go to the tables tab, you’ll see that it thinks OGC is no longer installed/using that table and allows you to remove it. This could be confusing for “non-techy” users.

    I’m not sure why it thinks that, but for all other plugins that have created a table (in my case, Smush, Yoast and another plugin I now can’t remember), the issue does not exist, for some reason it’s only OGC

    Plugin Author José Miguel

    (@jomisica)

    @willstockstech,

    If the plugin can not apply the permissions to files in principle is because the id of the owner of the file is different from the id that runs the web server.

    Plugin Author José Miguel

    (@jomisica)

    As for the table in the database I will analyze.

    Try to create a topic for each question. It is difficult for me to respond to several things at once.

    Plugin Contributor Will Stocks

    (@willstockstech)

    I’ve logged it with my host (132175 for my future reference!) – very strange! OGC can create a folder, create/remove files and even remove the folder etc. – I would expect it to be able to set its perms

    Plugin Author José Miguel

    (@jomisica)

    @willstockstech,

    I realize your question Will, however chmod / touch among others can only be performed by the owner of the file / directory.

    Read: http://php.net/manual/en/function.chmod.php

    Plugin Author José Miguel

    (@jomisica)

    @willstockstech,

    In version 2 I already notice the user when there is this problem.

    Plugin Author José Miguel

    (@jomisica)

    @willstockstech,

    Confirm that the files / directories id is the same as the web server.

    However this only happened because you installed the plugin manually.

    Plugin Contributor Will Stocks

    (@willstockstech)

    Yes, I have asked my hosting provider to ensure that the account that runs WP has access to the folders.
    I installed the plugin via the “Add Plugin” WP-Admin option, not via FTP.

    Plugin Contributor Will Stocks

    (@willstockstech)

    Application account has now been set to default on my host (it was server that had admin, not the application) and now I’m able to press save without seeing the error 🙂

    I will get both application and server accounts setup so they can both manage the folders/files as necessary!

    Thanks for your assistance @jomisica

    Plugin Author José Miguel

    (@jomisica)

    Hello @willstockstech

    Thankfully the problem was solved.

    Thank you!

    Cihan Cesur

    (@cihancesur)

    Hi,

    I have the same problem, I gave 0777 file permission to directory but still can’t enable the plugin.

    Application account has now been set to default on my host

    How you did this? I use virtualmin and file owner as the same as rest of folders.

    Any suggestion ?

    Cihan Cesur

    (@cihancesur)

    I enabled plugin by editing options table in database. Plugin working properly and writing files to directory with no problem. I don’t know why giving file permission error.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.