Support » Fixing WordPress » Permissions Issues With Updating and Widgets Menu

  • Resolved goldferris

    (@goldferris)


    Hi!

    I’ve had my self-hosted WordPress blog (MakeupFiles.com) for over 3 years now. All of a sudden (I assume it happened after an update), WordPress doesn’t seem to think I have authority to make big changes.

    – Now, instead of giving me an “update automatically” link at the top of the admin for the new 3.2 update, it says “Please notify the site administrator.”

    – My Widgets menu has disappeared from the sidebar. I assume it’s also a permissions issue. I followed steps from other threads saying to change edit_theme to switch_theme in the functions file, but that didn’t get my Widgets menu back.

    For reference, I only have one user for my blog–Me-and it’s the default “admin” login username. None of that has changed.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Moderator kmessinger

    (@kmessinger)

    Do you use WP-Insert?

    http://wordpress.org/extend/plugins/wp-insert/

    Causes all the side bars in the admin dashboard to vanish. New version released on July 5th resolves this.

    Nope, I don’t have WP-Insert. And I’m not missing the sidebars. Just the “Widgets” menu from the Appearances section. Everything else is there.

    Moderator kmessinger

    (@kmessinger)

    Have you tried:

    – deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Don’t forget the ones in mu-plugins. If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    Thanks, Kmessinger.

    – I deactivated all plugins, signed out, and signed back in. It didn’t fix the problem.

    – I switched to Twenty Ten, signed out, and signed back in. It didn’t fix the problem (including the lack of “Widgets” in the Appearance menu.)

    Moderator kmessinger

    (@kmessinger)

    Go to dashboard users. Create a new user (you) – you will need a different email address – give that user admin rights. Log off and log on as the new user.

    I really don’t want to create a new user if I don’t have to (I prefer getting my WordPress emails at the email address I chose originally). Is there a way to change the current user (admin) to administrator? Perhaps in PHPmyAdmin panel in the database?

    So? Delete the old admin user and then change the email address back to your preferred one.

    Okay, I added a new user, assigned it as an “Administrator.” Then I logged in as that user and it has the same problems as the original. It still says I need to contact the site admin to update wordpress, and there still isn’t a Widgets section in the Appearance menu.

    So, My problem still isn’t fixed.

    I’m still not sure what to do about this. I feel like my problem must be in the database somewhere, but I don’t know where to look. wp_users? wp_options?

    I searched around the internet and didn’t find anything.

    I thought about maybe updating WordPress manually, but I’m afraid that since I don’t have permissions anymore, it won’t let me complete the update once I upload it through FTP and sign in again. I’d hate to disable my site completely that way.

    And I still can’t edit my widgets anymore because of this, and that’s a problem.

    Anyone have any new advice. I haven’t gotten a reply in over a week.

    Using PhpMyadmin (or another MySQL managament tool), first backup your database. Then navigate to your wp_usermeta table and locate the meta_key called “wp_capabilities” for your user_id. Change the meta-value for this record to:

    a:1:{s:13:"administrator";b:1;}

    Thanks, Esmi…

    I found “wp_capabilities” in the database and the meta-value is already what you said it should be.

    I really don’t know what to do about this…

    Hi,
    Just floating an idea might be well off base, is this a multi-site install?

    I know that in multi-site you get this message and there are settings in wp-config that point to the primary blog id, might be worth a look?

    Do you have a membership plugin that has a capabilities matrix for different user types?

    Could be a plugin that is causing this?

    David

    Nope, this isn’t a multi-site install and I don’t have a membership plugin.

    It’s weird, because my usermeta data in the database has the administrator string “a:1:{s:13:”administrator”;b:1;}”.

    But it still doesn’t think I’m an administrator. I really am at a loss.

    I tried this thread, but it didn’t apply since mine already says administrator in the database: http://wordpress.org/support/topic/logged-in-as-admin-or-am-i

    And while this thread looked promising to me, like it might help my issue, I don’t understand it enough to apply it to my own situation: http://wordpress.org/support/topic/you-do-not-have-sufficient-permissions-to-update-plugins-for-this-blog?replies=9

    Sigh….

    Please, PLEASE someone help me. I’ll give you a virtual hug in return. You know you want one.

    I know I’m not supposed to bump, bu i last mentioned this a month ago and I still haven’t gotten a reply. Is there anyone out there that can help me?

    Moderator kmessinger

    (@kmessinger)

    Have you tried a diffent browser?

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Permissions Issues With Updating and Widgets Menu’ is closed to new replies.