Support » Plugins » Permissions issues with Amr Users plugin

  • I am using WordPress 2.8.6 and need user reporting. I have been using AmR Users for this and have been quite satisfied. When I upgrade the plugin from 2.3.5 to 2.3.7 I get an error message when I go to view any of the reports. It says that I don’t have sufficient permissions to see that page.

    Nor are the links to the reports available in the “Users” tray.

    When I backtrack to 2.3.5 version everything works OK again.

    Any ideas on how to fix this so I can use the most current version of Amr Users?

    As a side note (I don’t know if it would help fixing the bug) I get the following error message upon disactiving the Amr Users plugin (on both versions):

    Removed scheduled action

    Warning: Cannot modify header information – headers already sent by (output started at /home/xxxxxxxxx/public_html/xxxxxxxxx/wp-content/plugins/amr-users/amr-users.php:324) in /home/xxxxxxxxx/public_html/xxxxxxxxx/wp-includes/pluggable.php on line 865

    Thanks for any help!
    Matt

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi Matt,
    I have tried to recreate your problem without success (albeit not on your version of wp – all my various systems are on 3.0.x). I tried a clean website, with no other plugins etc. It works fine every where for me (without other plugins) etc.

    It does check the “list users” capability to determine whether to show the report links. If you are logged in as admin that should be fine.

    Maybe try logging off then logging on after activation? Sometimes clearing the cookies etc helps when you get a weird error like that

    Do you have any other plugins that maybe control access? or tried deactivating all, then reactivating one by one to see if there is a clash?

    Other than that:

    Have you considered upgrading wp? the latest 3.0.x upgrades had several security fixes in them – “older” wps tend to be the ones that are hacked especially once the security risks are made known.

    Re message, it is just saying that it removed the regular user report cacheing job (cleaning up after itself). I test with all errors etc switched on and it did not complain on my system, however I will probably remove that as it is not necessary really.
    Thank you for letting me know about that.

    Thanks Anmari.

    You are absolutely correct in that I need to make the jump to 3.0 In fact I was updating my plugins precisely in preparation for the core update. However there are still a few plugins that I am investigating workarounds for since they aren’t being maintained any longer. Until I get that sorted out I’ve reverted to 2.3.5 of the Users plugin.

    You do great work and your maintenance of the plugins is appreciated.

    Matt

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Permissions issues with Amr Users plugin’ is closed to new replies.