WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Permissions Error with 3.2.2 Update

[Resolved] Permissions Error with 3.2.2 Update

  • Hi!

    I updated today to HTTPS 3.2.2, but found that it somehow blocked the permissions on my website. My clients got a 403 error and were not able to access the website at all, while I was blocked from editing custom menus and other such things.

    I reverted back to HTTPS 3.2.1 and those problems went away. Not sure what was going on with the update though!

    Anyone else have this issue?

    http://wordpress.org/extend/plugins/wordpress-https/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Yep, me too,

    Ive been sticking with version 2.0.4 because every update after that has just not worked for me.

    Updated this plugin yesterday and was pleased to see it finally working OK.

    That is – until I tried to do some things in WP-Admin today.

    Really weird behavior; some of my other plugins just didn’t work at all, some redirected me to the login screen and a lot of the core functionality of wordpress would not work also.

    Basically, I couldn’t edit anything!

    The worst of it was, I thought we had been hacked again because I had accidentally left permissions on wp-content set to 0777 for several days prior to this happening.
    Spent most of the day deleting files and re-creating databases before I finally twigged to the reason.

    Running wp v3.4.2, php v5.3.18, MySQL v5.5.27 on an xen VPS with about 40 other plugins – which all play happily together – except this one.

    Reverted back to v 2.0.4, and all is well again.
    Keep up the good work Mike!

    Plugin Author Mike Ems

    @mvied

    Very strange. I haven’t had any issues. Any error logs or anything you can provide that may help me find a bug would be great.

    Unfortunately, I don’t have any logs at the moment. I encountered this error on a live website, and will not be able to mess with it for about a month. It most likely clashed with another plugin that I’m running.

    I just tried installing the latest version on my site and once activated (and force SSL is on the admin) it logs me out and when I log back in it says “You do not have sufficient permissions to access this page”.

    The only way I could find to fix this was to remove the plugin.

    How can I fix this please?

    Plugin Author Mike Ems

    @mvied

    Pay attention to the URL’s you are being redirected to. Enable the plugin and then browse to wp-login.php and ensure there is no redirect_to parameter in the URL. Let me know if that works.

    Hi it’s definitely not going to the wrong URL as I double checked and types it in manually several times. What else could be the problem?

    Plugin Author Mike Ems

    @mvied

    Not a clue. I don’t have this issue. The plugin does nothing with permissions.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Permissions Error with 3.2.2 Update’ is closed to new replies.