Support » Plugin: Contact Form 7 Signature Addon » Permissions error

  • Resolved macbookandrew

    (@macbookandrew)


    I’ve been using this plugin successfully on one site, but tried to install it on a different site on a shared hosting plan and am having trouble.

    Every time I try to submit a form with a signature, I get a 403 Access Denied error. I’ve tried manually creating the wpcf7_uploads and wpcf7_signatures folders in wp-content/uploads/ and even tried setting their permissions to 777, but am still getting the error.

    Nothing shows up in the PHP error log.

    Any tips for troubleshooting?

    https://wordpress.org/plugins/contact-form-7-signature-addon/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author tameroski

    (@tameroski)

    Hi,

    This is a known issue when servers are not allowing encoded file to be submit through form requests, which is the case on some shared hosting plan. Every workaround i tried did fail up to now unfortunately 🙁 Sorry for the inconvenience …

    For the sake of others in the future, my host was able to add a mod_security exception for a false positive, though they didn’t tell me what specifically triggered it in the first place.

    Plugin Author tameroski

    (@tameroski)

    Good to know. Thanks for the update.

    Yes, had the same problem. It was being blocked by ModSecurity. I contacted my host and they were more than happy to add a security exception to whitelist my web site.

    Working perfectly now. Lovely little plugin… many thanks. Great work!

    Plugin Author tameroski

    (@tameroski)

    Thanks for the feedback !
    Sticked topic

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Permissions error’ is closed to new replies.