Support » Plugin: Really Simple CAPTCHA » Permissions conundrum

  • Hi,

    I’m stumped lol. I’m using this plugin on my site, and on the current host, it works wonderfully. However, I’ve been tasked with moving the site to a new host provider, where I’ve had to literally create the cloud server and install everything from the ground up – which is why I feel I must have missed something, since the Captcha fails to validate.

    I’ll put a solid nickel on this being the issue: When the image/text files are being created, their permissions are 444 (image) and 440 (text). At first I found this was part of it by giving public write permissions on the folder (wpcf7_captcha), and at least it would generate the image. However obviously that’s not a good solution, and doesn’t solve the files being created from the plugin with their permissions. So then I tried granting ownership to Apache on everything (not so great either), even explicitly on that folder. This solved writing the files, and the image shows up, however it attempts to access the .txt file as a public user, and fails.

    Does anyone know what I can do here? I have a feeling it has to do with some sort of Apache configuration, but I’m really not sure what needs to be done. Any help is appreciated!!

Viewing 1 replies (of 1 total)
  • Update: I’ve made sure that www-data has full ownership of the ENTIRE site, including the images and text files that are being produced. Also made sure Apache is using www-data. What am I missing??

Viewing 1 replies (of 1 total)
  • The topic ‘Permissions conundrum’ is closed to new replies.