WordPress.org

Support

Support » Plugins and Hacks » TablePress » [Resolved] Permissions as admin

[Resolved] Permissions as admin

  • Hi,

    I’m having this issue for the first time. On a fresh install of WP, with some plugins and a premium theme, TablePress is not showing up in the admin menu and I can’t access the plugin page directly “You do not have sufficient permissions to access this admin page.”

    I tried to reinstall the plugin, deactivate the others, switch back to TwentyFourteen, nothing works. When I look at capabilities in User Role Editor, the tablepress’ capabilities are not even displayed. I don’t have this issue on other site with the same plugins setup.

    The theme in place is using the “Cherry Framework”, but it doesn’t seem to be the culprit since I have the same issue using TwentyFourteen.

    I can provide you access to the admin to help debug this.

    On a side note, I don’t have this issue on a local install with the same setup, TablePress is displaying alright.

    https://wordpress.org/plugins/tablepress/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Ok I deleted both TablePress and User role Editor, removed the settings for them in the database, reinstalled TablePress, and it’s now working. TablePress needs to be activated before User role editor, or it won’t work.

    Plugin Author TobiasBg

    @tobiasbg

    Hi Rémy,

    thanks for your post, and sorry for the trouble.

    Yes, User Role Editor seems to be resetting the WordPress capabilities when it is installed, and with that it also removes the TablePress capabilities.
    Another solution (besides what worked for you) is to simply restore the capabilities, with these instructions: http://wordpress.org/support/topic/troubles-with-tablepress-rights?replies=4#post-5585107

    Best wishes,
    Tobias

    P.S.: In case you haven’t, please rate TablePress here in the plugin directory. Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Permissions as admin’ is closed to new replies.
Skip to toolbar