WordPress.org

Forums

Really Simple CAPTCHA
Permission Problem (4 posts)

  1. Luca Preziati
    Member
    Posted 2 years ago #

    Hi,
    i use Really Simple CAPTCHA with CF7. When I send a message with form I got an permission error with unlink on line 219 (last version).
    I'm on aruba.it with windows hosting.
    I solve the message error, changing the permission to:

    /* Mode of temporary image files */
    		$this->file_mode = 0666;
    
    		/* Mode of temporary answer text files */
    		$this->answer_file_mode = 0660;

    But i check the temp file and was not cleanup.
    This happens also on my laptop with Wamp and windows 7.

  2. Luca Preziati
    Member
    Posted 2 years ago #

    I find a solution to clean the temp file, setting the permission as 0777.

    /* Mode of temporary image files */
    		$this->file_mode = 0777;
    
    		/* Mode of temporary answer text files */
    		$this->answer_file_mode = 0777;

    Do you think can find a more structured solution?

  3. gilu
    Member
    Posted 2 years ago #

    Can't believe it's still not fixed yet!
    After the update, had to redo this fix again! And not just for one site, nooooo!

    Chmod those files to 0660 helps. Don't think 0777 is necessary.

    Takayuki Miyoshi, could you please add that to your next release? Thanks!

  4. Vitzkrieg
    Member
    Posted 2 years ago #

    Thanks for the fix!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Really Simple CAPTCHA
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.