WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Permission denied/failed to open stream

[Resolved] Permission denied/failed to open stream

  • Hi,

    I’m having trouble moving a site from one GoDaddy domain to another. The first is a ‘permission denied’ error message (see below). I know I have to change the permissions to make it work but I’m not sure which folder/files permissions need to be adjusted?

    The second error (see below) tells me that duplicator could not open a stream due to a missing file/folder? I have no clue how to fix this.

    Thanks for the awesome plugin and the great customer service!

    Prechecks Completed

    Warning: ZipArchive::extractTo(/home/content/47/9850647/html/stats/index.html) [ziparchive.extractto]: failed to open stream: Permission denied in /home/content/47/9850647/html/installer.php on line 628
    ✔ Package Extracted

    Warning: file_get_contents(database.sql) [function.file-get-contents]: failed to open stream: No such file or directory in /home/content/47/9850647/html/installer.php on line 684

    http://wordpress.org/extend/plugins/duplicator/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Cory Lamle
    Participant

    @corylamleorg

    Hi Yemoonyah

    You can temporarily set the directory “/home/content/47/9850647/html/” to 777 (your root folder) then try to run the installer again.

    Hope that helps!

    SmashappStudios
    Member

    @smashappstudios

    I’m having the same exact problem with the same error. I can’t figure out how to change the home folders permissions with godaddy. I can change file permissions of files already under the root folder but not the root directory. How can I go about doing this? I’m desparate and don’t want to have to change hosting companies. My site has been down for 24 hours now and I’m losing money. Please help.

    [ Please do not bump, that’s not permitted here. ]

    Plugin Author Cory Lamle
    Participant

    @corylamleorg

    You might try this link

    SmashappStudios
    Member

    @smashappstudios

    Godaddy will not allow me to change the permissions on the root directory. I’m stuck. I just bought hosting through your link at host monster and tech support did a manual install there because the duplicator restore didn’t work either. Unfortunately, the website has missing content and has things like scrolling side bars that are missing now. I just want duplicator to work correctly so I can have my EXACT site back up and running. Can you help with this?

    Plugin Author Cory Lamle
    Participant

    @corylamleorg

    Hey SmachapStudios,

    The plugin does it’s bests to try and retore the site, however with thousands of different themes and over 100k+ plugins its impossible for the plugin to fix every scenerio. Sometimes manuall adjustments have to be made.

    If you want to submit a support ticket to support.lifeinthegrid.com I can take a look at your install, just mention again that you purchased through the affilate link and I’ll move you to the top of the queue…

    Also if you want to try version 0.4.0 its available in the development line. It has some bug fixes that may fix your issue. To get that version follow these instructions…

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/
    -> Look for the section “Other Versions”
    -> Click on “Development Version” and download the zip plugin file
    -> Uninstall your current version and install this one

    Please Note: To retain package sets go to options dialog -> system tab and uncheck ‘Delete entire snapshot directory when removing plugin’

    Plugin Author Cory Lamle
    Participant

    @corylamleorg

    Hey SmashappStudios,

    Any luck getting your site restored?

    Ok, so I finally found a solution:
    I uploaded the zip file and extracted (unzipped, unarchived) it manually. Then I went back to ‘yoursite.com/installer.php’ and clicked on ‘advanced options’. There I checked the ‘manually extract zip file’ and then followed normal procedure and voila! The Duplicator plugin worked it’s charm 🙂

    Plugin Author Cory Lamle
    Participant

    @corylamleorg

    Awesome! Thanks for the feedback!

    carpathia
    Member

    @carpathia

    Was getting the “… failed to open stream: Permission denied…” error using WildWest hosting. Just followed the advise of Yemoonyah. Worked for me as well. I’d had no trouble in the past with Godaddy hosting. When the Duplicator plugin is working it is the greatest! Merry Christmas.

    Plugin Author Cory Lamle
    Participant

    @corylamleorg

    Added a new section to the FAQs page:
    -> Browse To: http://lifeinthegrid.com/duplicator-faq/
    -> Find Section: “3. Troubleshoot”
    -> See Area: “Permission & System Issues”

    The quickest solution on a hosted environment is to contact the hosting companies support team. Because each host is different they will have different ways in which the group/owners and permissions under which PHP run are setup. In most cases they should point you in the right direction the fastest…

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Permission denied/failed to open stream’ is closed to new replies.