Support » Installing WordPress » permision problem with mysql

  • Hi!
    I got a problem with the permissions of my MySql-Database (I think…).

    On the description on your homepage I read:


    Note: These instructions are written for phpMyAdmin 2.6.0; the phpMyAdmin user interface can vary slightly between versions.

    1. If a database relating to WordPress does not already exist in the Database dropdown on the left, create one:
    1. Choose a name for your WordPress database (‘wordpress’ or ‘blog’ are good), enter it in the Create new database field, and click Create.
    2. Click the Home icon in the upper left to return to the main page, then click Privileges. If a user relating to WordPress does not already exist in the list of users, create one:
    1. Click Add a new User.
    2. Chose a username for WordPress (‘wordpress’ is good) and enter it in the User name field. (Be sure Use text field: is selected from the dropdown.)
    3. Choose a difficult-to-guess password (ideally containing a combination of upper- and lower-case letters, numbers, and symbols), and enter it in the Password field. (Be sure Use text field: is selected from the dropdown.) Re-enter the password in the Re-type field.
    4. Write down the username and password you chose.
    5. Leave all options under Global privileges at their defaults.
    6. Click Go.
    3. Return to the Privileges screen and click the Check privileges icon on the user you’ve just created for WordPress. In the Database-specific privileges section, select the database you’ve just created for WordPress under the Add privileges to the following database dropdown. The page will refresh with privileges for that database. Click Check All to select all privileges, and click Go.
    4. On the resulting page, make note of the host name listed after Server: at the top of the page. (This will usually be localhost.)


    Bute when I tryed to configure the “new user” there was “No Permision” (sry for the German Screenshot > “Keine Rechte”)

    Then I mailed my provider, he replied:
    “That is not a problem of the server, please contact the support of WordPress.”

    Now I am here ( is the provider)

    Would be nice to recive some help

Viewing 9 replies - 1 through 9 (of 9 total)
  • not realy sure what your doin wrong, but in your configure file for the WP your user name should look something like this…


    not just your user name part, but the whole user name.

    might help ya…kinda sounds like that may be it.

    thx for your response.
    Well, if (even before) tried to log in with:

    user: usr_web293_2
    pw: **********

    but the phpMyAdmin throw me back to the Login-Screen.
    I tried to log in as
    user: web293
    pw: **********
    as my provider told me.
    I was “in”, but “no permissions again (same screenshot like above –

    Another idea?

    sorry man… hopefully someone else can help.

    Maybe try starting over from scratch

    ‘blockquote’Maybe try starting over from scratch’blockqoute’
    done twice …
    same problem. seems to be a permanent permission problem.
    What I dont unterstand: The support of my hoster told me to ask the wordpress-support, but it seems to be a permission-problem in the clear database. thus it seems to be a problem of my host… :/

    solved, i was to stupid…

    Another Problem:
    WARNING: Your wp-content directory is NOT writable! We can not create the backup directory.

    whrere I should have a look? Permissions of the Database, od Problems with my space?


    May need to change permissions on wp-content to writeable (possibly chmod 777).

    Welcome to the WordPress Support Forums!

    Please help keep the Forums successful by reading:
    Using the Support Forums

    Also, remember the WordPress Codex and the FAQ pages.

    And, thank you, for letting us know if this information proves useful (or not)!

    When I changed the permissions for wp-content to 777 there was no error in these red boxes, but he complains in a popup that he was unable to create the backup-file.
    But then I reseted it to 775, cause 777 seems to be very unshure, isn’t it?

    Another Problem that maybe to be near by:


    Warning: weblog_ping(): Unable to access /srv/www/htdocs/web293/html/t/privat/blog/wp-includes/class-IXR.php in /srv/www/htdocs/web293/html/t/privat/blog/wp-includes/functions.php on line 851

    Warning: weblog_ping(/srv/www/htdocs/web293/html/t/privat/blog/wp-includes/class-IXR.php): failed to open stream: No such file or directory in /srv/www/htdocs/web293/html/t/privat/blog/wp-includes/functions.php on line 851

    Warning: weblog_ping(): Failed opening ‘/srv/www/htdocs/web293/html/t/privat/blog/wp-includes/class-IXR.php’ for inclusion (include_path=’.’) in /srv/www/htdocs/web293/html/t/privat/blog/wp-includes/functions.php on line 851

    Fatal error: Cannot instantiate non-existent class: ixr_client in /srv/www/htdocs/web293/html/t/privat/blog/wp-includes/functions.php on line 854


    Appears when I tried to save oder save&edit a post.
    The post appears on the blog, but I have to go the way ‘Edit’ again to stay on working on it.


    problem solved, as you can see in the link.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘permision problem with mysql’ is closed to new replies.