Support » Plugin: Forum - wpForo » Permalnk problem

  • Resolved bbhank

    (@bbhank)


    “wpForo can’t work with default permalink, please change permalink structure”

    I get this no matter what permalink structure is selected. When first installed it could not find its pages. Tries to go to Community directory and errors 404. Forum page has a number and can be edited by using its page id number.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Tomdever

    (@tomdever)

    Please navigate to Settings > Permalinks and set it /postname/, Then Uninstall (not just deactivate), Delete and Install wpForo again. Also please check it using other browsers or PC. Sometime 404 errors are being cached in local, so you can’t see it fixed or not.

    bbhank

    (@bbhank)

    Been there. Done that. No luck.

    Plugin Contributor gVectors Team

    (@gvectors-team)

    Have you checked regular posts an page? Do they work with SEO permalinks?
    And what about forum page? Does it work? Please leave some URL.

    bbhank

    (@bbhank)

    Did that and it won’t allow me to add the page to the main menu. Just sits and churns and never gives error or add menu item. This is what happened on first time I installed. No URL to leave because it won’t allow me to make menu item. The only wa it will show is with the View menu in the All Pages list. It errors when trying to edit:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 192 bytes)

    . It references a line number in these files: class-wp-post.php on line 240 and cache.php on line 672, neither of which contain any information about this page.

    • This reply was modified 3 months ago by bbhank.
    Plugin Contributor gVectors Team

    (@gvectors-team)

    This error is not wpForo error. And the problem comes from your server configuration. It seems the memory limit is too small, WordPress can’t work and can’t add a new item in dashboard menu. wpForo doesn’t have any relation to these issues. Please increase Memory and InputVars of your hosting service or change it.
    I’d recommend these values. Please contact to hosting service support and ask them configure your PHP with these values. Or just change the hosting service.

    post_max_size 100M
    memory_limit 256M
    max_input_vars 100000
    max_execution_time 60
    bbhank

    (@bbhank)

    Couldn’t help but notice: The default page for this plug in is not a page but a folder called Community in the root directory, which is not produced when the plugin installs. The setup gives the option to use folders only but not pages. I added the folder manually and when I try and access it I get “You don’t have permission to access /community/ on this server.
    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.”
    Not true. I’m the administrator.
    I tried the method suggested to change the php settings and that caused the home page and admin menus not to load.

    • This reply was modified 3 months ago by bbhank.
    • This reply was modified 3 months ago by bbhank.
    • This reply was modified 3 months ago by bbhank.
    • This reply was modified 3 months ago by bbhank.
    Plugin Contributor gVectors Team

    (@gvectors-team)

    I’m sorry but something is basically wrong on your website. Nothing works. I don’t think this is wpForo issue. Please install a fresh WordPress (make sure the tables are all removed before installing) then send admin login details to support[at]gvectors.com we’ll install wpForo ourselves.

    bbhank

    (@bbhank)

    You were on it while I was reloading it. Try again. It’s back.

    Plugin Contributor gVectors Team

    (@gvectors-team)

    I don’t know your website URL. I’ve never been on your website. Please read my last post. Saying “nothing works” I mean something is basically incorrect and wpForo fully stuck on your website. I need a fresh installation to check it.

    bbhank

    (@bbhank)

    OK. I didn’t think I had given it out.
    Please see previous post about the Community folder.
    Reinstalling right now.
    Thank you for working with this so fast.

    • This reply was modified 3 months ago by bbhank.
    bbhank

    (@bbhank)

    Check this out:
    Had an idea. I moved the community folder to a lower level directory and changed the Forum Base URL to reflect this. This worked. I this case it does not work if the community folder is in the root directory.
    Will post any more problems I have with this.
    Thank you.

    Had to give out some stars for the responsiveness and persistence of the support crew.

    • This reply was modified 3 months ago by bbhank.
    • This reply was modified 3 months ago by bbhank.
Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.