WordPress.org

Support

Support » How-To and Troubleshooting » Permalinks – "You should update your web.config now"

Permalinks – "You should update your web.config now"

  • I’m trying to change the permalinks to the postname, but when I try to update it says I need to update web.config. All the links on my site are broken. Can someone please tell me what I need to write in the web.config file? (I don’t have access to the .htacess file.)

Viewing 15 replies - 1 through 15 (of 22 total)
  • Anyone know what I can do to fix the links?

    what is the link to your site? web.config will involve a windows server so you wont have a .htaccess file. What version of wordpress are you running?

    You really should not be running WordPress on a windows server. You should move it to linux but try this in your web.config file. Your web.config file is not writable on your server so you must add this manually.

    <rule name=”wordpress” patternSyntax=”Wildcard”>

    <match url=”*” />

    <conditions>

    <add input=”{REQUEST_FILENAME}” matchType=”IsFile” negate=”true” />

    <add input=”{REQUEST_FILENAME}” matchType=”IsDirectory” negate=”true” />

    </conditions>

    <action type=”Rewrite” url=”index.php” />

    </rule>

    I have 3.3.1 and the site is http://www.reneekatz.com/

    I should be on a Linux server, does it matter I use a Windows OS on my computer?

    When I wrote that code in, the site says: Parse error: syntax error, unexpected ‘<‘ in D:\Hosting\8782496\html\wp-config.php on line 85

    wp-config and web.config are two different files.

    Copy and past the error you got when you tried to change the permalink structure and remove any of the code I told you to add to web.config

    Okay it does say “web.config”. This is what shows up at the top of the wordpress admin page when I try to save the new permalink settings: “You should update your web.config now”

    I think this web.config is a file I can’t access because of GoDaddy permissions, because I can’t see it…

    Are you sure you are on a linux server? web.config is associated with a windows sever. Can you see it if you login to godaddy and use there ftp file manager?

    No I am NOT on a linux server, I am on a Windows server. And no I can’t see it on their FTP file manager either. Im completely lost now.

    This sucks cause I need to be able to change the permalinks as a very basic function of WordPress. 🙁

    move to a linux server and all your problems will be resolved.

    Try creating a web.config file and add the code I gave you earlier and upload it to the server and see if that fixes it. Otherwise I would highly recommend switching to linux.

    I had a client recently that wanted to be on a windows server and I told them it was a bad idea. We launched and had plenty of issues so they had me move it to linux like I suggested and have not had an issue sense.

    I have told GoDaddy to move me to a Linux server! Thanks for the replies, I didn’t know this was free.

    Yes you can move server with no cost with godaddy. Sorry I should have specified. How long did they say it would take? I think typically it can take a few days?

    Yeah, 72 hours at the most.

    Cool, If you need anymore help after it is moved I would be happy to help. Just post it her and I will get back to you, but you should be all set. If so please mark this thread as resolved.

    thanks and good luck.

    Hey jclark32, I’m having the same issue and I am on a windows server as well. I will get godaddy to move it, but I need to update this now.

    I’m also running wordpress 3.3.1.

    Can you tell me what code to add in to which file? Thanks!

    Try the code above. Add it to your web.config file. Is there anything in your web.config file right now

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Permalinks – "You should update your web.config now"’ is closed to new replies.
Skip to toolbar