Support » Fixing WordPress » Permalinks (Yay!)

  • OK, my latest problem.

    I thought I would change my permalinks from /year/month/postname/ to /category/postname/. They were working fine until this point.

    Of course, this messed up everything and now when I’ve tried to put it back to the way it was it won’t work again. I’ve tried the following:

    – Deleting all content in the database and adding the one that worked again, so the permalinks are back to their old setting.

    – deleting the new .htaccess and adding the old one from a backup, which was working.

    – changing permissions on the .htaccess file to 777

    – checking that mod_rewrite is on with my server. checking allowoverideAll is enabled

    That’s it, I don’t know what else to try now. Does anyone have any ideas? I’m having so much goddam trouble with WordPress lately, wasted an entire week trying to get it to work as it was, after the updgrade which doesn’t work. What the hell is wrong with it?!

    Cheers, sorry for whinging.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Just to add to this, something is wrong with the permalink update I think. If I click on the links to the categories, it just uses the normal category ID (eg: /blog/?cat=1), which obviously works.

    When I click individual posts, it tries to use them as permalinks, which no longer works.

    OK, this seems to be working now, sorry for posting without trying a few more things, but they did work fine before without having to do the following:

    On this page, do a search for Fixing Permalink Problems, then server blockage below that. This tells you to force Apache basically.

    Never was a problem before though….

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Permalinks (Yay!)’ is closed to new replies.