[resolved] Permalinks Won't Work! (4 posts)

  1. panantukan
    Posted 6 years ago #


    I can't get any permalinks other than the default setting on my site to work. On my localhost I've gotten permalinks to work just fine, but online it won't work even if I set htaccess to 777.

    Does this indicate that the problem is with my host's server or could WordPress possibly be the cause of this?

  2. panantukan
    Posted 6 years ago #

    I have solved the problem. I found that in addition to using the correct permission settings in htaccess you must also add rules to the htaccess file. WordPress attempts to do this automatically, but my server would not allow it.

    When you press the button to change the permalink type wordpress creates a new box that has the code you need to copy paste into htaccess. The box is not visible unless you scroll down.

    Hope this helps.

  3. richardforeman
    Posted 6 years ago #

    Are you talking about on the admin page under settings and permalinks? I checked that page and did not find any box.

  4. richardforeman
    Posted 6 years ago #

    Found the problem, the post status on the posts was set to 0 instead of publish. Fixed that now on to the pages part.

Topic Closed

This topic has been closed to new replies.

About this Topic