Support » Fixing WordPress » Permalinks – won’t save my preferences

  • Hi all.
    I recently installed WordPress, and I’m having a problem with permalinks. In the admin section under Options->Permalinks I should be able to change the permalink structure from the default to “date and name based” or “numeric”, but when I click “Update permalink structure” it switches back to the default. The note comes up that says “permalink structure updated,” so it seems to think it worked.

    Is there a way to fix this so that I can change the permalinks? Do I need to reinstall and start over? I’m skeptical that that would fix it, since it never worked properly to begin with.

    Thanks,
    Taygeta

Viewing 8 replies - 1 through 8 (of 8 total)
  • Jeremy Clark

    (@jeremyclark13)

    Member

    If you scroll down to the bottom of that page after updating what does it say? Does it say that the .htaccess file isn’t writable or doesn’t exisit.

    It doesn’t mention the .htaccess file. The only things that change when I update are that the radio button changes to the default, and at the top I get the message “permalink structure updated.”

    Jeremy Clark

    (@jeremyclark13)

    Member

    Are you using an apache webserver that has mod_rewrite?

    Um, do I have to create the .htaccess file when I get started, or is it there to begin with?

    My website is on 100webspace, and it’s an Apache server, but I don’t know about the mod_rewrite….

    Jeremy Clark

    (@jeremyclark13)

    Member

    If your blog root isn’t world writable (which is shouldn’t be) then yes you’ll have to create the file and change it’s permissions to 777 then change your permalinks then change it back to 775
    Good resource:
    http://codex.wordpress.org/Using_Permalinks

    Ok, I’ll try that. Thanks.

    Didn’t work.

    I changed the permissions to 777 and then tried to change the permalinks, and it didn’t work. Then I followed the instructions in the Using Permalinks article you gave, under the Fixing Permalink Problems section. Still nothing. My .htaccess file says:
    # BEGIN WordPress

    # END WordPress

    and nothing else. So it wrote something, at least.
    Any ideas?
    Thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Permalinks – won’t save my preferences’ is closed to new replies.