Permalinks without index.php? (11 posts)

  1. mystique
    Posted 10 years ago #

    I have cvs'd to 1.5-alpha-6 and I'm trying to use permalinks. wp has created the .htaccess with my desired structure:

    but if I take the /index.php out the mod_rewrite doesn't work and I get things like:
    http://site.com/archives/2004/.. doesn't exist
    and in the apache error logs it's looking for /usr/local/www/wordpress//archives/2004/..

    any clues?

  2. That means that you host has not enabled mod_rewrite (and probably won't), or because you're not on an Apache server (only Apache supports mod_rewrite) . You're stuck with /index.php/.

  3. mystique
    Posted 10 years ago #

    I am on a host that has mod_rewrite, and I do have apache..

    Server Version: Apache/1.3.33 (Unix) mod_ssl/2.8.22 OpenSSL/0.9.7d
    mod_gzip/ mod_perl/1.29 PHP/4.3.10
    Server Built: Dec 9 2004 22:12:08

  4. Hm, go to Options/Permalinks (this is critical that you go there and leave it up, we're going to yank .htaccess out from under it). Now, open your FTP app, go to your WordPress directory, and make sure you can see invisible files. Delete .htaccess. Now, create your permalink structure as /archives/%year%/%monthnum%/%day%/%postname%/ . This should create a new .htaccess file, and should work. More than likely v1.5, being an alpha release, is having difficulty with overwriting .htaccess.

  5. mystique
    Posted 10 years ago #


    I removed the .htaccess and when I opened the Permalinks page it re-created it.

    I removed it again pasted in what you suggested and it made the .htaccess that is listed at the above link.

  6. I'm not an expert on v1.5's .htaccess structure. My best guess would be that it's the PHP tags (<?php and ?>) getting in the way. I've never seen PHP tags in a .htaccess file before. It's a shame that there is no such thing as an online .htaccess validator.

  7. mystique
    Posted 10 years ago #

    that comes from pastebin :)

  8. BenDG
    Posted 10 years ago #

    There really shouldn't be any php tags in .htaccess. Neither should it be writable by apache (security risk). Just generate the right code in WP, then select all > copy > paste into an editor on yor server (or locally and upload).

  9. mikkeltsch
    Posted 10 years ago #

    I can't get my permalink working either, without index.php. mod_rewrite is enabled, I'm using apache of course, but still, I get "Not Found" when trying to hit the directories

    Possibly tried any sollution possible, without any working result

  10. FionaDixit
    Posted 10 years ago #

    There seems to be an awful lot of talk about this and 1.5. I never had an issue with until I upgraded to 1.5.

    Now I have to put that wretched index.php at the front of my permalinks in options.

    My mod-rewrite is fine. I checked and they are being written.

    I have yet to see an authorative reply to this problem. Is there one?


  11. FionaDixit
    Posted 10 years ago #

    I guess not!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.