Support » How-To and Troubleshooting » [Resolved] Permalinks with 1and1

[Resolved] Permalinks with 1and1

  • Okay, so I tried to customize my urls throught the permalink settings. WordPress says the insert this into my .htaccess because the file is not writable.
    ‘<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    Well the only .htaccess file i see is in my logs folder. Which 1and1 will not let me edit or change the permissions for. I believe I read on 1and1 faq to create a .htaccess file and put it in the folder i want it to effect. I also read somewhere to put this in the wpcontent folder. So I pasted that code in notepad, names the file .htaccess and uploaded it to wpcontent. This did nothing. So then I moved it to my (/.) folder. That knocked down my whole site.
    Its so confusing. Different articles say to do different stuff. All I want is wordpress to be able to overwrite my .htaccess file and allow me to have custom permalinks. How do i do this? I’ve looked through similiar topics on this forum and they havent helped.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Mark Ratledge


    Forum Moderator

    Delete the .htaccess files in both wp-content and in root and then use your FTP (like Filezilla) client to make a new file in the top level of your host, i.e. the same level as the wp-config.php file. Look for a New File command in your FTP client.

    Using the FTP client to make the file will make sure the file gets created with the correct file format and character encoding. You can change the permissions on .htaccess to 755 and let WP write the changes when you set permalinks, or you can cut and paste them in, too.

    You also need to add these lines to the top of your .htaccess to enable php5 on 1and1; it’s a problem just with that hosting service:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Thank you so much! It worked.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Permalinks with 1and1’ is closed to new replies.