WordPress.org

Support

Support » How-To and Troubleshooting » Permalinks with 1&1

Permalinks with 1&1

  • Hi,

    I’ve been desperately trying to get my permalinks setup, but no matter what I do, I keep getting the same message:

    If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    I’ve tried adding this code, as well as some alternatives I dug up on forums, but none worked. I’ve also changed permissions to several different things, didn’t fix the issue.

    I tried creating a new file, but FileZilla doesn’t seem to give you the option to create a new file directly on the server.

    Anyway, I appreciate any help! Happy to give more info.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Do you see a .htaccess file on your server when you connect with FileZilla? If not, you could just create a htaccess.txt file on your desktop and paste in the rewrite rules, then after uploading it, rename it to .htaccess on the server.

    Thanks for your response.

    Yes, I originally saw an htaccess file on the server. I actually eventually deleted and re-created using the method you described in my previous troubleshooting efforts, but it didn’t help unfortunately.

    In FileZilla you could change the .htaccess permissions to 777 (be sure to make note of what they are originally so you can change them back later), go update your permalinks in the admin area, then change the permissions back to what they were originally.

    What permalink structure are you attempting to setup?

    is there a way to delete all the defined permalinks from the database thru phpmyadmin?

    esmi

    @esmi

    Forum Moderator

    @emilysparkle: It is impolite and contrary to forum policy to interrupt another poster’s ongoing thread with a question of your own. Please post your own topic.

    interesting, i thought my question was right on topic and would be helpful for the OP to also know. every forum has different rules. it was not my intention to butt in.

    I changed the file permissions to 777, and then back to 755 after I had refreshed the permalinks page. Still seeing the note about the htaccess not being writable.

    I’m trying to do post names.

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Permalinks with 1&1’ is closed to new replies.