permalinks still have index.php, with mod rewrite (5 posts)

  1. Kelly Dwan
    Posted 5 years ago #


    I'm having a lot of trouble with a network install - I currently have three sites on one install, with domain mapping such that one of them is off at dev-m.org (obviously not a real url, but none of the sites are actually at real URLs), the main site is at dev-s.com, and the third is at dev-s.com/portfolio. That last is empty so it's not a concern right now.

    I'm trying to get permalinks to work, and I'm nearly there, but it's not working. I can get to the pages if I use the "index.php/permalink" method, or default permalinks (?p=1), but not just "permalink". I'm on apache, and I know for a fact that mod_rewrite is enabled - I have other WP installs that still work, and this one worked before I domain-mapped it (which also had me messing with virtual hosts, which is a bit out of my depth).

    The issue I was having before was that I'd set up the virtual host wrong, so it could be that again... That file is here [at pastebin].

    Alternately it seems that WP is just ignoring my .htaccess file - telling me it's updated when it hasn't (I had tested this by deleting the file, updating permalinks- and getting the success messages, but the file still didn't exist when I looked). So if it's any help, here's my .htaccess [again, pastebin].

    Hopefully someone can help me, or at least point me in the right direction.

    Edit: I forgot to say that the 'not working' behavior I get is that it just displays the index page.

  2. Are you setting these up locally on Windows with WAMP?

  3. Did permalinks work when it was a SingleSite or were you always stuck with Almost pretty?


  4. Kelly Dwan
    Posted 5 years ago #

    Andrea - no, it's a VPS running ubuntu

    Ipstenu - not only did they work when it was single, it worked as multi-site before I did domain mapping.

  5. Aha! That's important info! Which I missed first time through, sorry...

    What are your options set to in httpd.conf? And is AllowOverride set to All?

Topic Closed

This topic has been closed to new replies.

About this Topic