Permalinks staying ugly despite changes (5 posts)

  1. NealJMD
    Posted 5 years ago #

    Hey guys,

    I'm working on my first wordpress site. I got everything working perfectly locally on a windows 7 machine with XAMPP, but I've now uploaded to a free host to allow admins to populate content, and I'm running into trouble with the permalinks. The site is at sfer.comze.com

    Specifically, my pages instead of displaying as /about/who-we-are are displaying as /?page_id=1044. What I understand I'm supposed to do is to go change the permalink settings at Dashboard > Settings > Permalinks. However, I already have Day and Name selected, the same as locally. Additionally, if I go to edit the page, instead of having an edit button where I can edit the permalink, it just has a button for "Change Permalinks" that brings me back to the Permalink settings page.

    My guess is that something needs to be changed in my .htaccess file. Currently it only reads:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    which was written to it by wordpress (permissions are 666). I've of course looked through the documentation but it seems I'm missing something fairly obvious because I haven't found other people unable to get their page permalinks to go pretty.

    Thanks for your time!

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Is mod_rewrite running on your local server?

  3. NealJMD
    Posted 5 years ago #

    Yes I believe so. My httpd.conf file has the line
    LoadModule rewrite_module modules/mod_rewrite.so
    (not commented out or anything). I am unsure whether it's enabled on my remote host (which is where I have the issue). I tried adding
    RewriteBase /
    at the top of my .htaccess file as it says that turns it on here but that had no effect.

    Edit: I can now confirm that mod_rewrite is also enabled on the server, it's listed under apache loaded modules.

  4. NealJMD
    Posted 5 years ago #

    Also, I'm not sure if this matters but it could tip somebody off - the urls are using two slashes after the main root, such as http://sfer.comze.com//wp-admin or http://sfer.comze.com//?page_id=1046. I tried changing RewriteBase / to RewriteBase in my .htaccess file but that turned every page into a 500 error.

  5. esmi
    Forum Moderator
    Posted 5 years ago #

    What urls have been entered in Settings->General?

Topic Closed

This topic has been closed to new replies.

About this Topic