WordPress.org

Support

Support » Multisite » Permalinks re-directing to home

Permalinks re-directing to home

  • I have set my permalinks in the dashboard after moving my install to another domain name. There appears to be a re-direct that pushes the permalinks to the main domain. The url has the permalink so I know they are being written, they are just re-directing to home. If I take off permalinks all the links work. I know I am missing something simple in how I have configured the 1st site.

    This ties in with my Network Admin not re-directing – I have to type in the whole URL and it works, also things like uploading plugins re-directs.

    The sub-site permalinks all work perfectly.

Viewing 15 replies - 1 through 15 (of 16 total)
  • What’s the content of your htaccess?

    How did you edit your DB after your moved domains?

    After having serialization issues, I deleted the DB and ,moved the original DB as per the instructions on your site, I was left with 1 area that I couldn’t re-write. I didn’t have an fileupload_url that you specify needs changing in wp_options.

    Then you have to manually (again) review all the wp_x_options tables and look for THREE fields:
    home
    siteurl
    fileupload_url

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    I can’t wait to see this fixed, it’s been a long trek, thanks for you help.

    Hmm. The directions on my site aren’t for moving, but for ditching ms-files. Those are two very different things, and doing both at once is a recipe for disaster.

    So let me ask this again: When you moved DOMAINS, and only domains, how did you do it?

    It may be cross wires on my part, it’s the same info as the codex that I used. This support post is identical to mine I think. http://wordpress.org/support/topic/multisite-cant-login-to-super-admin?replies=18

    We were both on IP addresses to begin with.

    Sorry, I’m not bumping – just expanding on what’s here:

    Then you have to manually (again) review all the wp_x_options tables and look for THREE fields:
    home
    siteurl
    fileupload_url

    upload_url_path and upload_path are blank in all of my options – I don’t have fileupload_url, the main site is not listed in a wp_x_options, it is in wp_options – I assume that is correct for the main site.

    Okay, http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Multisite aren’t MY directions 😉 That’s the codex, and that’s everyone’s. Hence my confusion.

    And that goes back to the initial question: What did you do?

    Your answer should be something like this: I used the search/replace DB tool to change IP 123.45.67.89 to domain.com and then I changed the domain name in my wp-config.php to domain.com

    upload_url_path and upload_path are all blank in 3.4 installs and up, that’s okay.

    fileupload_url should be only set in wp_options.

    (See, I know you said ‘I replaced it’ but there are SO many different ways people do these things, I really need to know what YOU did 🙂 Since I can’t lean over and see your setup, I have to be pedantic and exact so I can give you the right advice.)

    Hi Sorry, I was on my temp server which was under a different domain name as I couldn’t set a domain reference, the idea was the client hosted with me but they wanted to stick with their existing co in the end so I added a 1 to the domain thinking I would just map to the reference when it was ready.

    OLD htaccess

    RewriteEngine Off
    SetEnv DEFAULT_PHP_VERSION 53
    DirectoryIndex index.cgi index.php
    
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /oldsitename1.co.uk/
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    # END WordPress

    NEW

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    I downloaded a local copy of the old DB.

    I changed wp-options site and home from http://111.11.111.11/oldsitename1.co.uk to http://www.newsitename.co.uk

    I have no fileupload_url in the table to change – if there is a set option ID I can confirm this.

    wp_site old domain 111.11.11.11 path /oldsitename1.co.uk
    wp_site new newsitename.co.uk path/

    wp_blog #1 old domain 111.11.11.11 path /oldsitename1.co.uk
    #3 old domain 111.11.11.11 path /oldsitename1.co.uk/subsitethatworksperfectly.co.uk

    wp_blog #1 new domain newsitename.co.uk path/
    #3 new domain newsitename.co.uk path /subsitethatworksperfectly.co.uk

    #3 wp_options as per normal but this is working normally

    I used a find and replace in notepad for the wp_posts changes from http://111.11.111.11/oldsitename1.co.uk to http://www.newsitename.co.uk – I exported the table on it’s own so these are nowhere else in the tables.

    Once done, I imported the database to the new sql database.

    Apologies, if I missed a step, I have been switching between the old and new DB to find the changes.

    Oh… You both changed domains and moved folders. Ick.

    wp_site – Correctly done 🙂

    wp_blogs (not blog) – I think you did that right… It should be be:

    domain: foo.com
    path: /

    for all of them (with sub.foo.com for the domain for subsites etc)

    Have you saved permalinks in your sites? I mean gone in via wp-admin and pressed save?

    Yes permalinks were saved. I have just tried again and seen something else, I know everyone has an issue with the permalink having blog inserted on the main site. Mine isn’t trying to do that. My permalinks are going as mysite.co.uk/sales rather than mysite.co.uk/blog/sales even though the permalinks page shows the option with /blog/.

    The subsites are set as they should be in the permalinks page mysite.co.uk/subsite/03/07/blogpostname

    in WP_options I have the full http://www.mysite.co.uk in site and home, I don’t have a wp_2_options and the first subsite is wp_3_options

    If I get an incorrect page in the main site I am re-directed to home but in the subsites I throw a normal 404. Equally, I can’t install a plugin in network admin as I am re-directed to login.

    I can’t help but think it’s just one place in the database (maybe wishful thinking).

    My permalinks are going as mysite.co.uk/sales rather than mysite.co.uk/blog/sales even though the permalinks page shows the option with /blog/

    Interesting…

    Go to /wp-admin/network/site-settings.php?id=1 (i.e. Edit settings for Site #1) and see what “Permalink Structure” is set to?

    I tried this looking at another post today, I can’t access the settings – just get re-directed. I can get to sites but when I try to get to edit or type the url I get this.
    http://www.mysite.co.uk/wp-login.php?redirect_to=http%3A%2F%2Fmysite.co.uk%2Fwp-admin%2Fnetwork%2Fsite-info.php%3Fid%3D1&reauth=1
    I am just taken to log back in.

    It seems that in Network Admin I can access the dashboard and all top level navigation, i.e. sites but when I try to go into the sub pages i.e. edit I get logged out.

    Looks like www is redirecting to NON www as well… when did that start?

    Ugh. it looks like the search/replace wasn’t done correctly, but that doesn’t make a whole lot of sense based on what you said

    I had issues previously so I didn’t do a search and replace anywhere except in the posts table. wp_options was changed manually and only in 2 places. I can see in there that the old domain is still all over it.

    I dropped the database that had issues and started with a clean copy.

    This issue has been there from the start as mentioned here in the original post.

    This ties in with my Network Admin not re-directing – I have to type in the whole URL and it works, also things like uploading plugins re-directs.

    As I had issues previously with doing a search and replace I specifically only did it in the posts, nothing else was altered.

    Could it be that as I have gone from serverIP/olddomain.co.uk to newdomain.co.uk/ that I have got a configuration wrong. I was extra careful the second time I followed the instructions as you can imagine.

    Could it be that as I have gone from serverIP/olddomain.co.uk to newdomain.co.uk

    It’s very possible. It’s something that isn’t recommended.

    You could TRY moving from serverIP/olddomain.co.uk to serverIP (or do it locally on your PC and use your hosts file to fake the domain name). it’d be easier (and safer) to test that.

    Yes – I tried a few things locally but I got the same result. If I was to talk the client into hosting with me and I mapped the real domain to my perfect running copy are there any issues that you know of that could cause issues, I have lots of mapped domains to normal installs but this install has been a complete eye opener. I am not taking anything that I think I know for granted.

    I might actually map a domain I own that I don’t use to my test server as a trial. Sorry, talking out loud…

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Permalinks re-directing to home’ is closed to new replies.
Skip to toolbar