Support » Fixing WordPress » Permalinks Question

  • Hi all,

    I searched for the answer to my question and found a lot on the subject of permalinks.
    I am trying to set them using this string:

    /index.php/archives/%year%/%monthnum%/%postname%/

    According to what I found I do not need to change the mod_rewrite rules if I set it up this way.

    However, when I use that and click on a permalink I get an error message: “No input file specified.”

    Any advice or help is appreciated! Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Have you put the permalink rewrite rules into a .htaccess file?

    Hi NuclearMoose!

    I thought if you used index.php as the start you did not need to use rewrite rules? It says this on the permalinks page:

    “In general for this you must use mod_rewrite, however if you put a filename at the beginning WordPress will attempt to use that to pass the arguments, for example:

    /index.php/archives/%year%/%monthnum%/%day%/%postname%/

    If you use this option you can ignore the mod_rewrite rules.”

    If I do need to add this, how do I do so? I am not familiar with the .htaccess file.

    thanks!

    Moderator Ryan Boren

    (@ryan)

    WordPress Dev

    You don’t rewrite rules, but you do need to turn on path info. If your server is Apache 2.0.30 or later, add this to your .htaccess.

    <Files "index.php">
    AcceptPathInfo On
    </Files>

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Permalinks Question’ is closed to new replies.