Support » Fixing WordPress » Permalinks – only the default works

  • Resolved zzzmuzz

    (@zzzmuzz)



    If I try to change to any other permalink structure I get an “Oops Page not found:” error on the Blog page.

    Ideally I would like to change the permalink structure to:
    /blog/%postname%-%post_id%/
    as recommended at http://docs.appthemes.com/tutorials/wordpress-permalink-structure/

    Or even to /%postname%/

    The blog is fairly new and can’t think of any hard links which would cause the problem. I noted elsewhere that one user said his provider needed to do an .htaccess sync or something…not sure what this was about though.

    Ideas?

Viewing 15 replies - 1 through 15 (of 16 total)
  • You will need check with host if Mod_rewrite is enabled if yes then did you try and select post name selection if you using 3.3.1

    Thanks govpatel: Yes I have tried post name selection and it didn’t work as noted above. I am checking in regards to Mod_rewrite and will report back.

    Richard: Thanks for the link which I had already been to and to many others. Did you see something on those pages which particularly addressed the issue because I didn’t?

    Cheers,

    Yes Mod_rewrite is enabled with Vodahost

    Is your .htaccess file present in your WordPress home directory?

    Absolutely …yes

    Cool, and is it writable?

    If .htaccess file not writable you will be given the code to add to the file.
    As this fresh install did you try and reinstall.

    Thanks for the help.

    Yes, it is writable.

    What’s in the .htaccess file when you try to use one of the other preset permalinks?

    I am just going out to work..was just going to check ht access after changing to another style and got>

    Your attempt to change your permalink structure to: has failed.

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Thanks esmi et al. Will check out your suggestions. It may be a day or two as I have Vodahost working on the installation in regards to the “An automated WordPress update has failed to complete”.

    But I will get back with feedback.

    Have deactivated all plugins. This did not help as the Blog page still showed OOps that wasnt found (using postname permalink).

    Same thing happened (with different wording) when using 20/20 theme.

    Reactivated theme (Flexsqueeze) – Blog page still not working
    Went back to default permalink scheme and got 404 not found error.

    Cleared Firefox cache. Still got 404 not found error.

    Opened site in Chrome — site comes up with Blog working correctly.

    Changed back to Custom permalink which I was originally try to use: /%postname%-%post_id%/

    It installs correctly in FF and Chrome.

    BUT, in FF the Blog page still comes up with OOPS etc
    but Chrome is fine!

    I have cleared FF Cache over and over, will now close FF, reboot PC and see what happens.

    what ever is there is problem in your .htaccess file try and rename file to say .htaccess-bak and create another .htaccess file and then reset permalinks

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Permalinks – only the default works’ is closed to new replies.