Support » Networking WordPress » Permalinks – only Post IDs work

  • Resolved cbartle3

    (@cbartle3)


    Presently, the only way to maintain navigation in my site is to set permalinks to plain. I’d prefer to use the post name. I’ve enabled read/write access to .htaccess, and upon setting the permalinks to post name, .htaccess looks like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /health/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /health/index.php [L]
    </IfModule>
    
    # END WordPress

    This file is blank if I set permalinks to plain (save for the beginning and ending comments). Is there any way to remedy this?

    Note: The static front page works in either scenario.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Steve Stern

    (@sterndata)

    Guardian of the Interwebs

    How are you hosting your site?

    It’s hosted on a college server.

    Moderator Steve Stern

    (@sterndata)

    Guardian of the Interwebs

    Contact the sysadmin for your server and ask them to add “AllowOverride All” to the <Directory> block for your <VirtualHost>. It’s probably set to “None”, so your .htaccess file gets ignored.

    I’ll look into this and see if that is the case. I appreciate the help, thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.