WordPress.org

Support

Support » How-To and Troubleshooting » Permalinks on Netfirms

Permalinks on Netfirms

  • dailyjapan

    @dailyjapan

    Hi,

    Has anyone had any luck getting permalinks to work with netfirms hosting? I have played around with it, but always get 404 errors when I try and click around.

    Do I have to do something special on the server with mod_rewrite? Or does netfirms not support this at all?

    Thanks,

    Chris

Viewing 15 replies - 16 through 30 (of 32 total)
  • To comment on the netfirms vs wordpress permalink issue, I’m running into the same issue with Netfirms.

    However…

    I know of a blog running wordpress 2.0.2 on a different host, that has permalinks running fine.
    I setup a blog running wordpress 2.0.3 on yet another host, that has permalinks running fine.
    I setup a blog running wordpress 2.0.4 on netfirms, that permalinks doesn’t work with. It was previously running wordpress 1.5 for which permalinks didn’t work either.

    I’ve logged a support request with netfirms to solve this issue, but haven’t heard back yet.

    Something tells me it’s not a wordpress issue – why would 2.0.2 and 2.0.3 work on other hosts, but 2.0.4 and 1.5 not work on netfirms? I’m guessing there weren’t many changes between 2.0.2, 2.0.3 and 2.0.4 that related to permalinks. It’s a fairly straightforward issue.

    Yes, it is a straightforward issue: Pretty Permalinks (sans index.php) ain’t gonna happen without AllowOverride on.

    They directed me to the page below – which seems to indicate that it’ll work, but they haven’t any examples that use REQUEST_FILENAME .. I verified that it’ll do rewrite’s, but it just wouldn’t do anything with the wordpress generated .htaccess configuration.

    http://support.netfirms.com/idx.php/0/696/article/How-do-I-configure-URL-forwarding-using-modrewrite.html

    I haven’t figured out a proper solution, but it seems pre-pending “index.php” to your permalink structure allows it to work.

    So, in the wp-admin tool, under options -> permalinks, enter this into “custom, specify below:” /index.php/%year%/%monthnum%/%day%/%postname%/

    I found this here:
    http://weblogtoolscollection.com/archives/2004/06/01/use-nice-permalinks-in-wordpress-without-the-use-of-mod_rewrite/

    I’m guessing netfirms is running off IIS or some non-apache rewrite module, which is causing the problems.

    I’m having the same issue. It’s really very annoying as I only set up the site a couple of days ago, and I’m already considering chucking NetFirms (the FTP access is slow too).

    I’m running with the standard WP-generated .htaccess file, and permalinks don’t work properly.

    Can anyone post a non-working permalink on a Netfirms hosted site, so I can compare to mine? Cheers.

    Qmnonic, they aren’t running via IIS:

    curl -I http://www.earthmostlyharmless.net/2006/09/14/comments-not-working/
    HTTP/1.1 200 OK
    Date: Thu, 14 Sep 2006 22:26:09 GMT
    Server: Apache/1.3.34 (Unix) mod_perl/1.26
    X-Pingback: http://www.earthmostlyharmless.net/xmlrpc.php
    X-Powered-By: PHP/5.0.5
    Vary: NFInfo
    Content-Type: text/html; charset=UTF-8
    X-Pad: avoid browser bug
    X-Cache: MISS from www.earthmostlyharmless.net

    I’m having the same problem. I just set up a WordPress 2.0.4 site on Netfirms, have identical settings to a WP 2.0.4 site that I have setup elsewhere (GoDaddy), and the permalinks do not work unless I add index.php to the structure, which is definitely not what I want.

    BigRedBall666, you can check out the broken permalinks on my test site http://www.awstoronto.com, although I’m playing around with it so am occasionally switching back to the index.php structure to try things out. All of the navigation at the top is broken except for the first link (Upcoming Events), since it is the home page, and the last link (Blog) which is hard-coded for now.

    As an aside, I’m also concerned about Netfirms’ slowness, I have ftp performance problems but also really serious database performance problems, which impacts loading any of the pages on my WP site.

    As an FYI, I had netfirms support looking into the issue (I set them up an instance of wordpress with permalinks for them to debug, they wouldn’t look into it themselves). After 5 days of nothing, I cancelled and switched to http://www.superwebhost.ca and haven’t had any issues. The http://www.superwebhost.ca info pages are slow, but my site is fast and I have no issues with permalinks.

    I had problem with WordPress Permalink with Netfirm hosting.
    Sometimes it works, but comment link doesn’t work.

    I got it figured out by selecting Custom option and put /index.php/archives/%post_id%/ in the custom structure field.

    Steve
    [sig moderated]

    Ah, that works for me also:

    /index.php/%year%/%monthnum%/%postname%/

    I’d love to figure out a way to get that index.php out of there, though. Otherwise I guess I’ll have to establish redirects from my old Blogger URls.

    If you have read carefully the whole thread you could see that on netfirms there is no way to get rid of the “index.php” part… which means regardless what they say – nice permalinks do NOT work on their server.
    Get a normal host, that’s the only solution.

    Thanx for the info, I was just wondering about this — they’re offering what looks like a pretty good deal, but not having nice permalinks taints it.

    Torley, I would have never gone with Netfirms if I had known about the permalinks problem, and I’ve also had some serious performance problems. I have another WP blog on godaddy.com, which I know has its own set of problems, but permalinks are not one of them: it behaves pretty well and is about the same price. As for Netfirms, I signed up for a year because it dropped the price further, and since it’s for a non-profit organization’s site that I run, I can’t just forget it and pay again for another hosting company, so I think that I’m stuck on Netfirms for the year. Won’t be renewing, however.

    I created a new blog using the latest version WordPress 2.0.5

    Permalinks works without any modifications. Just make sure that you have .htaccess turned on in the control panel.

    Go to WordPress admin and click on Option and Permalinks. Then select “Date and name based” so the urls will look like /2006/11/08/sample-post/

    Seeds, that’s a nice fantasy, but it doesn’t actually work on Netfirms. If you change the options as stated, all links become broken and just link to the home page. That’s the whole point of this post. You have to have “index.php” in the URL or it doesn’t work.

    Netfirms technical support explicitly told me that they do not provide AllowOverride on .htaccess, which is why this doesn’t work; until they can support that, we’re all screwed on this issue as long as we keep hosting on Netfirms.

    ***SOLUTION***

    I was furious when I read this (spent 10+ hours trying to fix it) and contacted Netfirms. They responded with this solution which has worked for my site hosted with Netfirms.

    Your .htaccess file should have this instead of the standard WordPress generated file:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !index.php
    RewriteRule (.*) /index.php/$1 [L]
    </IfModule>

    # END WordPress

    This code gets rid of the /index.php/ part of the tag. I believe it is a work around instead of full support by them.

    You probably should turn the CHMOD to a setting like 644 so the WordPress control panel will not accidently overwrite the fix and return you to square one.

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘Permalinks on Netfirms’ is closed to new replies.
Skip to toolbar