Support » Fixing WordPress » Permalinks on Netfirms

  • Hi,

    Has anyone had any luck getting permalinks to work with netfirms hosting? I have played around with it, but always get 404 errors when I try and click around.

    Do I have to do something special on the server with mod_rewrite? Or does netfirms not support this at all?

    Thanks,

    Chris

Viewing 15 replies - 1 through 15 (of 32 total)
  • I guess its just not possible?

    Ask your host whether they support mod_rewrite or not. You cannot do anything about it.

    Moderator James Huff

    (@macmanx)

    Have you tried all of the troubleshooting tips?

    http://codex.wordpress.org/Using_Permalinks#Fixing_Permalink_Problems

    You will also need to ask netfirms about mod_rewrite support. We don’t know if they support it, but I’m sure that they know.

    Now netfirm is lying (not the first time, btw) – if you need to put in the “index.php” bit, then they do not support anything 🙂

    I’ve just set up WP2.0 up on a Netfirms hosted domain (I tried to use their one click installer but it went all screwy so I installed it manually) and I’m getting the same problem.

    The fix that Seeds linked to above doesn’t work for me at all.

    WP should update the .htaccess file automatically when I change the Permalink structure yes? I don’t need to chmod to 666(?) or something fancy before changing my settings in the QP admin? I’m (obviously) a bit new to both WP and Apache.

    My .htaccess is currently

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php
    </IfModule>
    # END WordPress

    edit:
    sorry, reading this thread
    http://wordpress.org/support/topic/63887?replies=10
    are the contents of .htaccess irrelevant anyway?

    also, I’ve uploaded the two updated files from this thread to no avail
    http://wordpress.org/support/topic/54340?replies=39#post-298609

    If the .htaccess file is not writable (=chmod 666) then WP cannot write “automatically” to it. Yes, you do have to change the permissions on the .htaccess file.

    Thanks Moshu. I’m thinking perhaps it’s not relevant anyway under WP 2, based on what I’ve read.
    The contents of the .htaccess file don’t seem to be updated in response to changes to the Permalink options in the admin at any rate, no matter what it’s permissions are set to.

    Since WP.2.x the rewrite rules are handled internally (whatever that means, don’t ask, I am not a coder 🙂 BUT seemingly you still have to chmod the file. Its content is the same for everybody.

    Cool thanks. I have what seems to be the standard in there so I’ll just keep an eye out. It looks like a few people have had issues since upgrading to 2.x

    Sorry to bump this but I thought an answer would be better than to leave the thread open ended.

    I emailed their support, they replied – a day or so later:

    At the moment, we do not offer AllowOverride for .htaccess. It has been added to our list of client requested features and may be included in a future service upgrade.

    So I guess in this case they’re not being entirely truthful. Their support pages specifically mention that they support mod_rewrite, but unless I don’t quite understand how it works (quite possible) they don’t actually support it at all.

    Shame.

    OK last necropost.

    It’s only fair I note that the latest newsletter from Netfirms notes that mod_rewrite is now supported (on at least some of their hosting packages, mine included)

    I’ve not tested it, but in theory it’s now officially supported.

    I am using Netfirms as well. I have WP 2.0.2 manually installed. My permalinks work only in default. I have .htaccess turned on but as previously posted this should not be an issue. I have chmod to 666.

    I have tried numerous ways to get the “pretty permalinks” to work but no luck thus far.

    If anyone else figures out why this is happening and how to fix it, please advise.

    Other than getting a decent host… I don’t really know what to say.
    You cannot find one single postive mentioning of your host in this forum.

    I am paid up with Netfirms for another 7 months but honestly, I have had no problems with them. The tech support people have helped me fix so many things. I don’t think my permalink problem has anything to do with Netfirms. I think it has to do with permalinks in 2.0.2 not working for everybody and no one having a clue how to fix them. I did a search for 2.0 and permalinks and dozens of threads concerning this issue come up.

    Previously I had installed Word Press through Netfirms (2.0.1) and my permalinks were fine. Then I thought I should upgrade because of the security issue. That is when I lost a years worth of blogs (my fault, but Netfirms helped me retrieve a back-up file).

    As soon as I manually installed Word Press 2.0.2 everything went south. I have stripped my site down to the bare bones in an attempt to fix the permalink problem but nothing works and I have lost traffic as a result. Again, it is my fault that I lost a years worth of blogs and it was my choice not to try and get them back up. I just thought a fresh install might be all I needed.

    I am not a code expert and I think I got in way over my head trying to manually install Word Press. If it were not for the tech support people at Netfirms, there would be nothing on my page right now. As for 2.0.2 I don’t know if the security benefits of having it are worth all the trouble I have gone through in the last 3 weeks trying to get it to work. If anyone finds a way to fix the permalink issue in 2.0.2 I hope they post it for those of us who still can not figure it out.

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘Permalinks on Netfirms’ is closed to new replies.