Support » Fixing WordPress » Permalinks Not Working, Tried all the fixes

  • Resolved TIves


    Hi all,

    Would love your insights here… please!

    Just moved a site to a new domain and the permalinks no longer work. Here is what I have done so far to fix the issue…

    • In the database I did a replace of the old URL to the new URL in the wp-options table (for site-ulr and home)
    • and the wp-posts table (guid and post_content).
    • I also deleted the contents of rewrite_rules in wp-options and they were properly re-written.
    • I have de-actived SEO plugins
    • and I have gone to Settings -> Permalinks and set them to defauly (which works) and then back to “Post Name” (which does not work).

    The generated html has the correct permalink name in it and this matches what is stored in the table wp_posts field “post_name” (this was confirmed by executing a search in the dB using a cut’n paste from the html).

    If I manually type the URL using the default GET method (“?p=”) I get to the article, even If I have selected the “Post Name” option in Settings -> Permalinks.

    One last note… I do not have access the htaccess file.

    Any thoughts?

    Thanks so much!


Viewing 7 replies - 1 through 7 (of 7 total)
  • catacaustic


    very awesome

    The main thing that would be the cause of this is that the .htaccess file either wasn’t transferred across with the rest of the files (some FTP clients don’t read or see hidden files), or that the new hosting server doesn’t allow for the .htaccess file to be created/updated when the permalink changes are made. There’s also a possibility that the server might not allow Apache’s rewrite module which is what lets the permalinks work. You should be able to see if there’s a .htaccess file in the WordPress directory. If there isn’t then move the one from your old server onto the new server. You can also create a new one on your hosting server and let WordPress update that automatically.

    Thanks for the idea Catacaustic. Unfortunately, the hosting provider does not allow the creation of .htacess files via any mechanism (cannot create the file, transfer the file, rename a file, etc.) This is true for both the old site and the new site (same provider).

    If I were to call the host provider, what should I ask them to do? Simply delete the contents and let WP take care of it from there?

    Thanks again!




    very awesome

    If they don’t allow for a .htaccess file, how did the first site work? :/ Something sounds fishy about that. It’s the .htaccess file that lets the permalinks work so without that you get what you have now. If they don’t allow it to be there, then it would have been the same on the first site. I doubt that deleting and re-installing would help. If the file cant’ be created then it won’t be created by doing the same thing again.

    As much as it would be a hassle I’d look at moving to a different host if they can’t work that out for you. it’s a simple, standard and common requirement that most PHP-based CMS systems need. If they can’t provide that, there’s 1,000’s of other hosts out there that can.

    Is it possible that the .htaccess file simply resides in a directory above my root? That is what I assumed was their implementation (as to why, I don’t know). The provider is Yahoo Small Business which has a reasonable price-point and decent support, but is notorious for not allowing access to .htaccess. So, if there is in-fact an .htacess file residing above my root, do you think they may be able to manipulate it accordingly or am I simply off-base?





    very awesome

    I don’t think that’s possible. I’ve enver seen that work before so it’s pretty unlikely. I don’t know the way that their servers work so I can’t be sure of how they’ve set it all up.

    I haven’t used the Yahoo! hosting service before, but from what I’ve seen on their site, I wouldn’t use them. Expecially for WordPress. They don’t allow a few basic things ( like the .htaccess file). You might not need some or all of them, but in this case you do, so it’s not going to work.

    There’s a lot of hosting companies out there that will do better at hosting and will be the same price or cheaper.

    Thanks! I appreciate the advice and will look into other providers. Yes, there have been a few times that I have wanted to make changes to (or implement) an .htaccess file, but have not been able to.

    This is from Yahoo…

    Yahoo! does not currently allow you to upload .htaccess files to your account. For other customization options, we recommend the Custom Error Pages and password-protection features available in your Web Hosting Control Panel.

    All the best!


    Ahhh, found a solution. After calling Yahoo Small Business, only to find out that they architected their environment to have only one shared .htacess file (don’t ask me why), I was about to drop the site and rebuild from scratch.

    Then, I found a link on the blog manager page asking “Did your links change?” After clicking on that I was provided an option that rebuilt the links such that pretty permalinks worked again.

    Thanks for all the help Catacaustic!


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Permalinks Not Working, Tried all the fixes’ is closed to new replies.