• This refers to a wordpress.org installation on a Synology NAS. The webserver is NGINX (although the NAS settings say it’s Apache, it isn’t – the process table shows nginx).

    On the website, I recently enabled permalinks because I found the ?page=## too cumbersome. Since then, all pages except the main page generate 404 not found error. Searching the web about this I found hints that the .htaccess file might need permission alteration. Surprisingly, I couldn’t find that file in the root of the website. This is the root directory:

    $ ls -a
    index.php readme.html .well-known wp-admin wp-comments-post.php wp-config-sample.php wp-cron.php wp-links-opml.php wp-login.php wp-settings.php wp-trackback.php license.txt wp-activate.php wp-blog-header.php wp-config.php wp-content wp-includes wp-load.php wp-mail.php wp-signup.php xmlrpc.php

    $ find . -name “.htaccess”
    ./wp-content/uploads/wpforms/.htaccess
    ./wp-content/uploads/woocommerce_uploads/.htaccess
    ./wp-content/uploads/wc-logs/.htaccess

    I believe NGINX tries to be as compatible with Apache as it can. So, I assume it can handle an .htaccess file. Am I missing something?

    This installation just updated to WordPress version: 6.3.1

    Thanks,
    Frank

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Permalinks not working, htaccess file missing’ is closed to new replies.