WordPress.org

Forums

WooCommerce - excelling eCommerce
Permalinks not working for me.. (9 posts)

  1. ltaa09
    Member
    Posted 1 year ago #

    Ok so i have woo commerce installed and i went and changed the perma links of "Product permalink base" from the default to my custom one thats "/%product_cat%" well the shop works right the products show up under that permalink but the problem is that if i make a custom permalink like that it doesnt allow me to access to the pages like cart, my account, ect. By the way i do have the standard pages that come with woo commerce when you install it. Also im new to word press and woo commerce so if you could please take it step by step that'd be great! Thank you in advance for help! One last thing if you were wondering what it says when i cant access the page is this:

    "Error 404 - Page not found!

    The page you trying to reach does not exist, or has been moved. Please use the menus or the search box to find what you are looking for."

    http://wordpress.org/plugins/woocommerce/

  2. dannzeman
    Member
    Posted 1 year ago #

    I'm experiencing a similar issue. Would love to find a solution.

  3. designedaudio
    Member
    Posted 1 year ago #

    Same problem as well. Gawwwwww!

  4. Basz85
    Member
    Posted 1 year ago #

    Did you make also an .htaccces file? This can be done dueing in your WordPress panel.
    Copy the code, paste in a notepad file and save as it: .htaccess (all files) and upload it to the webserver.

    It works fine by me with the permalinks.

  5. ltaa09
    Member
    Posted 1 year ago #

    Hey everyone! I Think i found a solution and honestly is the most simple thing.

    1: Login to your wordpress admin panel (www.YourWordpressSite.com/wp-admin)

    2: On the left hand side go to Settings > Permalinks

    3: Scroll all the way down to the bottom under 'Product permalink base' from here you can select one of the premaid links or select a 'Custom Base'

    4: If you selected to use a Custom Base you need to have your shop directory in part of it for example this will NOT work /%product_cat%/ the reason this will not work is because it is missing the shop directory. To make this one work for you would need to do this /shop/%product_cat%/ this would work because it contains the shop directory.

    Thats basically it. You dont need to have the same thing i have, /shop/%product_cat%/, you can also change after /shop/ to whatever you want to make it more customized. Hope this helped! Fixed my problem i was having!

  6. ttstauss
    Member
    Posted 1 year ago #

    I'm not sure how a custom base of /shop/%product_cat%/ is any different than the provided option of "Shop base with category".

    Is there a way to remove the /shop/ portion of the url?

    i.e. - http://example.com/product-category/product (where 'product-category' would be the category of the product chosen).

    I tried entering /%product_cat%/ in the custom base field and it yields the desired results, however (as stated above), many of the other pages will no longer work.

    Any ideas?

  7. mkalinska
    Member
    Posted 1 year ago #

    upgraded from 2.0.14 to 2.0.19 and have the same problem. version 2.0.14 was OK

  8. Willem-Siebe
    Member
    Posted 1 year ago #

    Hi,

    I would like to get this structure (I had it before but can't manage it anymore)

    shop-page/category-name/product-slug/

    actually I have it working, but product caterory link still go to

    product-category/category-name/

    any ideas?

    Kind regards,

    Willem

  9. Willem-Siebe
    Member
    Posted 1 year ago #

    Actually what people describe here is exactly what I also have, last post person tells he had it working, me too!! But also bad luck :-(, how to get it working is the question.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic