Support » Fixing WordPress » Permalinks not working. both 2.51 & 2.6

  • I haveing problem with permalinks. It won’t cooperate 🙁

    I have read the codex page several times but maybe I’m to stupid 🙁

    I’m trying to use the “month and name” structure but then i click on a post all i get is: “Not found. The requested URL /2008/07/annu-en-idiot/ was not found on this server.”

    Wp can modify my .htaccess file. FollowSymLinks and Alloverride is as shown below. Still it won’t work. Please help me.

    <Directory /home/data/www/blog/*>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

Viewing 13 replies - 1 through 13 (of 13 total)
  • I just wanted to add that I’m having a similar problem. I was using the “Day and Name” permalink structure in 2.5.1 but when I upgraded to 2.6 it broke it.

    It now gives me a 404 not found if using the Day and Name or anything else but the Default.

    Nothing but the upgrade has changed, htaccess file is still the same as it was in 2.5.1

    I continue to also get permalink 404 errors after updating to WP 2.6.1. I understand many people are having this same issue.
    When will there be a WP release to correct this problem?

    Woot I’m not the only person, I thought I may have been alone! The bad news is many of us are having the same problem. Yesterday I spent most of my day trying to figure out what was wrong with mine, I had to put it back on the default for permalinks because that’s the only way they will work. I had it on date and name permalink, then suddenly they stopped working.

    Now outside links to my post just take people to my front page because they won’t work. Which sucks, I didn’t do an update either but maybe Yahoo! updated it as they are who I host through?

    The good news about multiple people having the same issue is that maybe it is due to an update or a glitch inside wordpress it’s self, if this is the case and many people are suffering from it, then maybe they will get it fixed soon.

    I never had this permalink problem with 2.5. I contacted my webhost and was told I had broken permalinks which is causing the 404 problem.
    They suggested changing the php configuration from PHP5 to PHP5(Fast CGI). Unfortunately this did not correct the permalink problem.

    Permalink problem also exists with people using 2.6.1 and 2.6 using IIS as well.

    I have the same problem with 2.6.2 upgrade.

    I have tried all of the above issues with no luck. I can not set security levels on the server.

    I support a number of data bases and to date have successfully updated one other but our main database has the permalinks problem. I regret upgrading. I just got sick of the nagging message to upgrade.

    I seriously wonder if the boffins the approvaled the “Stable” version really tested the product.

    If I include a .htaccess file on the root directory I can not logon to WP.

    I am not a happy camper. Yes it works using the default BUT…non permalink all our external links are now not working. The sitemap is wrong and google points to the wrong links

    PS using the Firefox browser is even worst. So it must have something to do with caching I guess.

    I upgraded to 2.6.2 hoping the permalink issue would go away. It didn’t. I have a linux server and any permalink with %postname% in it is not working-shows 404 error. Never had this issue previous to 2.6 release.

    I solved my prolem then I testet to set AllovOverride All on the root dir of my webserver( httpd.conf ), insted of only at the one containing the blog.

    Might be something to try 🙂

    I am just re-posting this here in hopes that my problem can get some help (the other post said ‘RESOLVED’ and of course it is not for me still!)

    I have been going CRAZY having problems with updating permalinks, trying to change my .htaccess file, etc, and I still can not view actual posts on my blog site, I’m really really frustrated now – if anyone can help, I would SO appreciate.

    Let me try to explain what happened so you could maybe better help me:

    1) First, I had an issue with one of those ‘500 – Internal Server Error’s (I had made a duplicate post that suddenly disallowed me to edit or delete any post). I managed to fix that issue by disabling and re-enabling/updating all of the plugins that I had set up for the blog (also I upgraded to WordPress 2.6.2).

    2) I also followed one user’s suggestion to change the permalink structure to the default, then I changed it back to the “Day and Name” permalink structure. This began the permalink problem.) Now I can not view any full post on my site:

    3) I will also note that all my blog files reside in the “” structure, but are viewable in the root folder – I still really think that this may have something to do with the problem

    4) Again, as I say, I tried to edit the contents of the .htaccess file / changing permissions of that file, etc, but this did still not resolve the problem.

    Also, I looked for what used to be the “update permalink” feature, but it looks as if they no longer have that in the latest (2.6.2) versions of the WordPress interface.

    Any help anyone can provide would be so greatly appreciated…

    Well this seems so crazy to me, but (maybe I kind of got this idea from reading someone else’s post), on the ‘Permalinks’ page, I changed the “Common Settings” from ‘Day and Name’ to ‘Custom Structure: /%year%/%monthnum%/%day%/%postname%/” and now all posts seem viewable under there names – so crazy, but just “Thank God” it works!

    Hope this can help anyone else struggling with this same difficult issue….

    same problem. permalinks only work as default. i was specifically trying to do the year/month/title permalinks. using latest version of WP

    @jpxwordpress tried your solution, no luck on my site.

    Sooooo….. did anyone find a fix for this?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Permalinks not working. both 2.51 & 2.6’ is closed to new replies.