WordPress.org

Forums

[resolved] permalinks not working after upgrade to 3.1. and 3.1.1 (52 posts)

  1. beclecto
    Member
    Posted 4 years ago #

    A month ago i upgraded to 3.1 and lost my month/post permalinks. I get only 404 messages when clicking on a specific article. I posted this issue elsewhere and someone suggested that it was my apache mod rewrite file on the server.. I called my host and they said nothing had been changed. I upgraded today to 3.1.1 hoping that it would be fixed with the upgrade but it still only works with the default setting.. I've lost over 1,000 percent of my traffic in the last month which was a shock.. and i'd surely like to resolve this issue but I need help. thanks in advance!

  2. Knut Sparhell
    Member
    Posted 4 years ago #

    Check your .htaccess file in the web root folder.

  3. beclecto
    Member
    Posted 4 years ago #

    ummmmm for what though? what am i looking for?

  4. Samuel B
    moderator
    Posted 4 years ago #

    do this
    delete the wordpress .htaccess
    now reset your permalinks to desired
    dashboard - settings - permalinks

  5. beclecto
    Member
    Posted 4 years ago #

    Wow.. I thought that was going to work.. wordpress created the new .htaccess file and with great anticipation I clicked on one of my articles.. a few actually, still getting 404 error arghhhhhhh!
    tried it again.. it will only accept the permalinks in the default mode.

    Thank you all so much for helping.. Any other suggestions?

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    Is mod_rewrite actually running on the server?

  7. beclecto
    Member
    Posted 4 years ago #

    Yes.. Host gator said that mod_rewrite is enabled by default on all of their servers. The tech also checked to be sure when i called.

  8. esmi
    Forum Moderator
    Posted 4 years ago #

    Was the .htaccess file correctly updated?

  9. beclecto
    Member
    Posted 4 years ago #

    .htaccess is created when I delete it. when i look at htaccess with notepad all it says is:
    # BEGIN WordPress

    # END WordPress
    it is 236K in size.

  10. beclecto
    Member
    Posted 4 years ago #

    I just got this error which i've gotten once before but there is some indication of apache activity..
    Not Found

    The requested URL /2011/01/kayak-anglers-new-fishing-paddle/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache mod_fcgid/2.3.6 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at beclecto.com Port 80

  11. reidt
    Member
    Posted 4 years ago #

    Seeing the same problem, but also when I try to edit the URL Link all I get is blank popup and unable to enter any Link URL or select any current pages.

  12. esmi
    Forum Moderator
    Posted 4 years ago #

    The .htaccess file isn't being amended/created correctly.

  13. esmi
    Forum Moderator
    Posted 4 years ago #

    @reidt: It is considered impolite to interrupt another poster's thread. Please post a new topic.

  14. reidt
    Member
    Posted 4 years ago #

    My apologies, my first time to the support forum.
    I considered that as I had the same problem with permalinks that the URL blank popup was an associated problem.

    Will post a new topic.

  15. beclecto
    Member
    Posted 4 years ago #

    esmi,

    okay, could it be a theme related issue? I notice you are the Theme Diva,

    Now what?

  16. esmi
    Forum Moderator
    Posted 4 years ago #

    I doubt it's theme related (more likely to be a server issue) but it wouldn't hurt to deactivate all plugins and switch to the Twenty Ten theme - just in case.

  17. beclecto
    Member
    Posted 4 years ago #

    Ugh.. ooookay leaving the computer right now for awhile I'll get on that this afternoon. Could if have something to do with permissions? chmod?

  18. esmi
    Forum Moderator
    Posted 4 years ago #

    I don't think so. WP obviously has access to the file - otherwise you wouldn't see the:

    # BEGIN WordPress

    # END WordPress

    additions. I'm at a loss to understand why it's not also adding in the re-write rules. I'm also amazed by its reported size. Are you sure it's not 236 bytes rather than 236K?

    On a related note, where is WordPress installed on the server? In the domain root? Or in a sub-folder?

  19. beclecto
    Member
    Posted 4 years ago #

    oh.. heck.. maybe it is 236 bytes.
    installed in domain root.
    what should the file look like?

  20. esmi
    Forum Moderator
    Posted 4 years ago #

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
  21. ignitionmedia
    Member
    Posted 4 years ago #

    I have the same problem
    I just updated mine from 3.1 to 3.1.2 & the permalinks broke

    My .htaccess file is perfect. I've deleted it, re-set me permalinks and re-created my .htaccess and it still wont work.

    My server is correct also

    any ideas?

  22. beclecto
    Member
    Posted 4 years ago #

    OH Wow... well i don't know what all makes that happen, but obviously my file is not being written properly. We now have a new (2and) poster claiming same problem. Are you helping others with similar issues? Should the wordpress folk be contacted? how is that accomplished? and how are you with joomla? :)

  23. beclecto
    Member
    Posted 4 years ago #

    could it be some corruption of index.php?

  24. ignitionmedia
    Member
    Posted 4 years ago #

    nope - i've installed 3.1.2 three times to make sure it wasnt a prob in the upgrade

  25. LachlanM
    Member
    Posted 4 years ago #

    Are you running a caching plugin, like WP Super Cache or W3 Total Cache? This could cause issues.

    I should note that those caching plugins are awesome, and would not likely be at fault themselves, however they also need some additional things added to .htaccess to run properly, and if you have a caching plugin installed and have removed your original .htaccess then this could cause an issue.

  26. ignitionmedia
    Member
    Posted 4 years ago #

    Nope, I just have WP e-Commerce plugin and even when I disable it, the permalinks are still not working.

    it is strange, when I go to look at a product category (http://trendykids.ignitionmedia.info/jeans-bottoms/) it works

    When I go to a normal page, i get nothing (404)

    the permalinks have gone very weird - im using /%category%/%postname%/

  27. beclecto
    Member
    Posted 4 years ago #

    esmi,

    this morning i updated to the new 3.1.2 version. I tried disabling plugins and no change. I deleted htaccess again changed the permalink structure to the custome month day i wanted. I checked the htaccess file and was thrilled to find "more" in there.
    '# BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress'

    Tried to click on an article and ... same old 404 message. I'm so frustrated.

    If you are still out there please help!

  28. esmi
    Forum Moderator
    Posted 4 years ago #

    I think you need to go back to your hosts. It really looks like mod_rewrite is not running.

  29. beclecto
    Member
    Posted 4 years ago #

    Just a word to let everyone know this issue is resolved. I contacted my host.. Hostgator.. again. I got a tech very familiar with wordpress. He changed my permalink to post name.. and it worked. it seemed that the "month,numb was causing some kind of issue. So while it wasn't a hosting problem with apache mod_rewrite, my knowledgeable host was able to fix the problem

    Thanks to all for their imput, specially esmi! Beclecto.com is back in business!

  30. esmi
    Forum Moderator
    Posted 4 years ago #

    I'm glad to hear that it's working now but a little concerned about the "fix". Apart from the fact that month and day should have worked just fine (which suggest that something isn't working somewhere), your current permalink structure is just about the worst you can have. See:

    http://wordpress.org/support/topic/423072
    http://ottopress.com/2010/category-in-permalinks-considered-harmful/

    If at all possible, I'd suggest that you at least try to use /%post_id%/%postname%/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags