• Hi

    After I activated the Awesome Support plugin, the WooCommerce permalinks for the products don’t work anymore.

    For example: I go to Settings > Permalinks and then set the permalinks to Shop base. So my Shop URL looks like domain.com/shop/product-name. Now when I active the Awesome Support plugin this URL doesn’t work anymore. I can set the permalinks to whatever I want, it doesn’t get changed. It always uses the Standard one like domain.com/product/product-name. As soon as I deactivate the Awesome Support Plugin the URL domain.com/shop/product-name works again.

    Do you may know any fix for that?

    Thank You.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author awesomesupport

    (@awesomesupport)

    Hi:

    Do you have any other plugins installed besides Awesome Support and WooCommerce? It could be the Awesome Support is actually conflicting with something else related to WC and not WC directly.

    Thanks.

    Hi,

    I deactivated all other plugins to test and it always was the same. As soon as I activate Awesome Support, only the standard WooCommerce permalinks work, like domain.com/product/product-name. All the other permalink variations don’t work anymore. It looks like Awesome Support messes up the permalink structure.

    Thank You.

    Plugin Author awesomesupport

    (@awesomesupport)

    Hi:

    We’ll try to reproduce this issue here but so far we’re unable to do so.

    Thanks.

    Same problem here.

    When i activate awesome – support . permalink stop working. And the default woocommerce is used /product/

    Some Help Will be appreciated.

    :(.

    Plugin Contributor elindydotcom

    (@elindydotcom)

    (removed)

    Plugin Author awesomesupport

    (@awesomesupport)

    Hi @amadoflimd

    Unfortunately, as mentioned above we’ve been unable to duplicate this issue. If the issue occurs with just WooCommerce and Awesome Support installed then there’s not a lot more we can do as far as helping to trouble-shoot this in a free forum.

    This is one of those issues that require more hands on trouble-shooting so its not something we can help further with in a free forum at this time. Its one of those things that either works or doesn’t. When it doesn’t and the only two plugins active are WC and AS then it probably comes down to things that are more configuration issues related to servers, php and other parts of the webstack. So right now we have no idea on where to direct you to next.

    If you have a paid license with us please open a ticket on our website. We’ll be able to then log into your test site and see if we can trouble-shoot the issue. But we’re all out of options in a free support forum at this time.

    Maybe one of the other members of the community might have some ideas?

    Thanks.

    So I found out when this issue happens. As soon as you use the sync products feature from the Awesome Support plugin, then the custom permalinks don’t work anymore.

    I installed WordPress on a test domain. Installed WooCommerce and then created a product. Changed the permalinks to domain.com/shop/productname. Then I installed Awesome Support and the updated the permalinks. The custom one with /shop still worked. Then I synced the products within Awesome Support, updated permalinks and then the /shop url didn’t work anymore. The permalinks were changed to domain.com/product/productname and I couldn’t change it anymore. So the issue has to do with adding the WooCommerce products to the Awesome Support plugin.

    I have that issue on 4 different Installations. 1 on localhost (using XAMPP) and 3 times on different hosting accounts.

    Thanks.

    Plugin Author awesomesupport

    (@awesomesupport)

    @dw71 – thanks for that update. We’ll do some tests with product syncing this week and see if we can duplicate the issue.

    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Permalinks not working’ is closed to new replies.