[resolved] Permalinks Not Working (4 posts)

  1. kouya
    Posted 3 years ago #

    my blog is http://www.kouya.net

    Two days ago, I decided to dump the thesis them and move over to 2011. I changed the theme, got the right widgets in the sidebar and everything was fine.

    Since then, I've not done anything to the blog as far as I know.

    This morning, I found that I could not see any of the posts. When I logged out from the admin panel, I could load up the blog. However, clicking on any permalink (page, post, category etc) gave me a 404. Others, using a variety of browsers found that they could not use the permalinks either, but the blog front page was fine.

    Since then, I have.

    1. Disabled all plugins and resaved the permalink structure
    2. Removed all plugins with an FTP client and resaved the permalink structure.
    3. Tried a variety of themes
    4. Placed a new .htaccess file in the root directory and resaved the permalink structure
    5. Repeated steps 1-4 numerous times and in various orders...

    None of this has had any effect. When I click on a permalink, I get a 404 file but I can access the home page (as long as I am not logged in).

    I've tried following all of the suggestions I can find on this forum.

    Nothing has changed on my server.

    I am now at my wits end.

    Any thoughts?

  2. kouya
    Posted 3 years ago #

    Further to the above. I have just noticed that I can't actually see any posts or pages from my dashboard. There are posts there - I can see them on the blog (as long as I'm not logged in) but they don't show up in the dashboard at all.

    thanks for any suggestions.

    Should I just nuke the installation and restore from a backup?

  3. ElShaddai Edwards
    Posted 3 years ago #

    I ran into something similar when I converted a site from another blogging platform to WP. Somehow all the posts got flipped from "Published" to "Pending Review" for their status, so they were visible when I was logged in, but when logged out produced the 404. That said, I could still see the posts in the dashboard, so maybe that's not the issue here.

  4. kouya
    Posted 3 years ago #

    I'm not sure what happened. But a couple of days ago, the problem resolved itself overnight without any input from me. Thanks Elshaddai for your input.

Topic Closed

This topic has been closed to new replies.

About this Topic