Support » Networking WordPress » Permalinks not working

  • Resolved Harpinder

    (@harpinder)


    Hi there,

    I have set up multi site environment like this

    network site – local.cms

    and then other sites on my local server
    site1.local.cms
    site2.local.cms
    site3.local.cms

    And then i added permalinks as “/blog/%year%/%monthnum%/%day%/%postname%/” (Custom Structure) so that i can display page-name in URL. example- http://local.cms/sample-page/, http://site1.local.cms/sample-page/

    All goes well except whenever i browse page links on site, it says – “Not Found
    The requested URL /sample-page/ was not found on this server.”

    I know i have to change the rules but i am not sure what should be the rules? Could anybody help me on this ??

    Thanks,
    Haprinder

Viewing 13 replies - 1 through 13 (of 13 total)
  • Harpinder

    (@harpinder)

    though it is working for http://local.cms/?page_id=2

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    The permalink rules in your .htaccess.

    What are they set to?

    Harpinder

    (@harpinder)

    thanks for reply. My .htaccess has following code:

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    
    # END WordPress

    an clue what i need to change here….

    thanks,

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    That looks fine for subdomains. If you turn OFF pretty permalinks, do the links work?

    Harpinder

    (@harpinder)

    By OFF, did you mean default setting like use of http://local.cms/?p=123 ?

    One more thing .htaccess file code remains same irrespective of any “Permalink Settings” in WP. Whether it is Custom Structure or Default or Day and name.

    Also, as told earlier, when i change the permalinks to “http://local.cms/?page_id=2” … links actually works!

    Not sure what i am missing?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Yes, the ?p= links are called ugly permalinks 🙂 and the .htaccess doesn’t change on save, you’re okay there.

    If the links work when they’re ugly but NOT when they’re pretty then your server is not set up correctly for mod rrewrite, and you need to ask your host for help with that.

    Harpinder

    (@harpinder)

    Thanks! I am doing this development in my local m/c. Here i have got another site also, but not multi site setup. Only single site setup. There all permalinks works fine.

    I thought i need to do some special for multi site setup but where not sure?

    ok and where these permalinks are stored then?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    If you’re doing this all via local host, then you probably just need to tweak your httpd.conf file and set AllowOverride to All. There was another fellow with the same issue just yesterday.

    The permalink settings are store in the database and WP dynamically generates the page using the .htaccess and database.

    Harpinder

    (@harpinder)

    Thanks for replying me promptly…

    I just checked my httpd.conf file and i think it is already “ALL”:

    <Directory “C:/var/www/html”>
    #
    # Possible values for the Options directive are “None”, “All”,
    # or any combination of:
    # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that “MultiViews” must be named *explicitly* — “Options All”
    # doesn’t give it to you.
    #
    # The Options directive is both complicated and important. Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be “All”, “None”, or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

    </Directory>

    I found this in another module, alias_module also.

    anyway, if you could just tell me where this page point to http://local.cms/sample-page/ … index.php ??

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    It points to index.php, which translates it 🙂

    Are you using WAMP? Check this topic, the last post has something that may help you

    http://wordpress.org/support/topic/wp-32-new-sites-not-working?replies=10

    Harpinder

    (@harpinder)

    Thanks for this info. You’r very right for AllowOverride setting. I have created cms.conf file and i not set this option there. Now, i have done this in cms.conf file and its working fine..

    Thanks a lot for you support.

    Harpinder

    iamsalmanafzal

    (@iamsalmanafzal)

    Please help me .. Permalinks not working on my live server, its work great on my local PC but on live server only default link is working and not others. its show.

    http://mysite.com/index.php/sample-post/

    and when i check “post name” to active this its show in input field

    /index.php/%postname%/

    What should i do to resolve this?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    iamsalmanafzal – Make your own topic.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Permalinks not working’ is closed to new replies.