WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] permalinks not working

[Resolved] permalinks not working

  • I have an install of wordpress setup and I can login to the admin no problem.

    The problem comes in when I start using any permalink setup other than the default (?p=123).

    After selecting a different permalink option, I can no longer access any page other than the homepage.

    Everything else is now a 404 error.

    even if I add an index.php after the domain, hhttp://honeycomb.ph/index.php/category/uncategorized/ , I still get redirected to http://honeycomb.ph/category/uncategorized/ and get an error.

    *I deleted the htaccess file I have just for the heck of it and wordpress still redirects my page to my home – http://www.domain.com (without the index.php file)

    help! point me to the right direction guys, what else could be causing the redirection / error?

    thanks,
    Jayson

Viewing 8 replies - 1 through 8 (of 8 total)
  • I had this and changed the following in the httpd.conf file:

    Changed AllowOverride None to AllowOverride All and now works

    For symlinks.

    Hope it helps.

    Hi muffintop,

    can you post your httpd.conf file here? my httpd.conf file is empty for some reason.

    thanks,

    Here you go:

    [huge amount of code moved to pastebin
    http://pastebin.com/bF6Y4UjM ]

    Hope this helps. Although if you have an empty httpd.conf you may have a bigger problem?

    I know right? maybe a bad install of apache? thanks, will try out your httpd.conf

    No worries, let us know how you get on.

    yeah… I don’t think that httpd.conf file will work for me. I have an Ubuntu 10.04 install on my server, I think, from your .conf file that you have windows?

    thanks,
    Jayson

    Yes, we are using Apache on Windows 2008.

    Apologies, didn’t really know what environment you were using.

    finally solved it.

    I found my answer in this one little comment here

    http://ubuntuforums.org/showthread.php?t=344995

    I strongly suggest that you don’t use htaccess, and instead use the <Directory /var/www/> directive in the /etc/apache2/sites-available/default config file. But if you insist on using htaccess, www-data needs to have read access, but should definitely not have write access.

    Which led me to check the file where it had AllowOverride None.

    *facepalm*

    so – for future reference, not only check httpd.conf but also /etc/apache2/sites-available/default (with no .conf extension).

    :O headache.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] permalinks not working’ is closed to new replies.
Skip to toolbar