WordPress.org

Forums

Permalinks not working (23 posts)

  1. NinjaStory
    Member
    Posted 6 years ago #

    See my blog at:

    http://www.urbaneblinds.co.uk/blinds-blog/

    I've turned permalinks on, however when clicking on a post I get the error message:

    NOT FOUND
    Sorry, but you are looking for something that isn't here.

    Am I missing something here? What could be wrong with this?

    Thanks. :)

  2. moshu
    Member
    Posted 6 years ago #

  3. NinjaStory
    Member
    Posted 6 years ago #

    Thanks for the link Moshu - I'm a bit of a WordPress novice though; which section should I be looking at?

  4. scribblerguy
    Member
    Posted 6 years ago #

  5. NinjaStory
    Member
    Posted 6 years ago #

    Thanks. I still can't work out the problem though. I have checked my .htaccess file, which reads:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blinds-blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blinds-blog/index.php [L]
    </IfModule>
    
    # END WordPress

    Does this suggest any problems?

  6. moshu
    Member
    Posted 6 years ago #

    Nope. All the htaccess files look the same.

    And when I give you a link to a resource in the Codex - I mean you read it ALL! + the related links from there.

  7. scribblerguy
    Member
    Posted 6 years ago #

    edit: Didn't refresh and see moshu's post. Anyway...

    Have you checked your server settings, per the Codex page? Mod_rewrite? Symlinks? Fileinfo?

    Install this plugin:
    AskApache Rewrite Rules Viewer and see if it reports anything unusual.

  8. christian_gnoth
    Member
    Posted 6 years ago #

    Hello,
    if you change the structure and click on "save" button, there should appear a message on to that the structure has been updated.

    do you get this message?

  9. NinjaStory
    Member
    Posted 6 years ago #

    Hi Christian

    Yes, I get the following message:

    Permalink structure updated.

    However, permalinks still don't work properly.

  10. NinjaStory
    Member
    Posted 6 years ago #

    Scribbler, sorry - missed your post. I installed that plugin, which tells me the following:

    > Permalink: /%year%/%monthnum%/%day%/%postname%/
    > Writable .htaccess file found
    > mod_rewrite found
    > Not using pathinfo style index permalinks
    > Using mod_rewrite permalinks

    This suggests everything should be working, does it not?

  11. NinjaStory
    Member
    Posted 6 years ago #

    Any ideas guys? I'm under pressure to get this live and I'm going out of my mind. I've read all the relevent documentation on the site and I'm still no closer. :(

  12. askapache
    Member
    Posted 6 years ago #

    Hmm. A few months ago I would've assumed it was a WP issue, but they've fixed everything as far as I know. And I really beat the crap out my installs and haven't had any issues with 2.5.1 yet so my guess is that its either some server configuration setting or its how the php interpreter is being used and was installed on your system.

    Do you can try looking at your basic .htaccess directives like Options, DirectoryIndex, ErrorDocument, and maybe you'll get lucky. Or you can try replacing that "Not Found" message with a phpinfo message (by setting up wordpress to output phpinfo from the 404.php) which could tell you if php is having some issues like pathinfo, and especially cgi stuff.

    But now that I look at your blog, maybe it is WP.. I think I remember having the same kind of problem when trying to post in a category that is a subcategory of another category. I bet it would work if you posted into a parent category. Something is wrong when your latest posts are in your /category/archives/finally folder. Should be /category/finallly or else you will have to make pages.

  13. NinjaStory
    Member
    Posted 6 years ago #

    Wow! I seem to have fixed it somehow, and it seems it was all so very basic. Basically, I had the category base set to /%category%/ which was screwing everything up.

    Trouble is, now my category URL's look like this:

    http://www.urbaneblinds.co.uk/blinds-blog/category/doing-business-online

    Is there an easy way to remove the category part of the URL?

    Thanks for all your help guys.

  14. NinjaStory
    Member
    Posted 6 years ago #

    Any ideas? :)

  15. sellhigh
    Member
    Posted 6 years ago #

    NinjaStory, this appears to be a common problem in WP 2.5 and I have not read of any fix for this. However, I was able to get it working on my site by changing my custom permalink from...

    /index.php/%postname%/

    to..

    /index.php/%postname

    Removing the %/ at the end got it working. Not sure why. The link that moshu posted is useless since it doesn't address this bug. Google it, a lot of people are having the same problem when "upgrading" to WP 2.5.

  16. ClaytonJames
    Member
    Posted 6 years ago #

    The link that moshu posted is useless since it doesn't address this bug...

    I'm not certain that it is a bug, and most certainly the link moshu gave you is not useless. It clearly states:

    "If you use postname as the only element in your permalinks to create a structure such as example.com/post-title, the rewrite rules may make it impossible to access pages such as your stylesheet (which has a similar format)" I think you have just found a work-around to an exception by altering the permalink structure so that it no longer bears similarities to the reasons why you should not use only /%postname%/ as stated in the documentation above. It is interesting to note that it ( /index.php/%postname), works though.

  17. ClaytonJames
    Member
    Posted 6 years ago #

    @NinjaStory

    Your site here: http://www.urbaneblinds.co.uk/ is clean, crisp and easy to navigate and read. In fact I was completely surprised by how fast it loaded on every page.

    Your blog, http://www.urbaneblinds.co.uk/blinds-blog/ blends in beautifully. I think it's a nice piece of work. I hope you get your permalink issues sorted out to your liking. I don't find anything odd about /%category%/%postname%/, but perhaps sellhigh's solution might be worth a try.

  18. NinjaStory
    Member
    Posted 6 years ago #

    Thanks for your help guys, and Clayton - thanks for the kind words.

  19. Roger Coathup
    Member
    Posted 6 years ago #

    I have the same problem.. in 2.5.1

    I set my permalink structure to /%category%/%postname%/

    It works fine for posts and categories, but won't display pages that are subpages of another page... it returns a 404 error.

    I also notice that it puts an extra / in the address line, i.e.:
    http://www.myblog.com//mypagename

    Any thoughts would be appreciated.

  20. LawrenceV
    Member
    Posted 6 years ago #

    Im having the same problem
    but after reading this thread and the information given
    i still cant resolve it
    /index.php/%postname
    works only hal way for me
    it shows the categories , but blog posts go BAD REQUEST
    could any body help me
    Maybe Ninja Story can tell me what to do ??
    thanks

  21. mrbingo99
    Member
    Posted 6 years ago #

    I had the same issue, but after reading these posts I changed:

    /%postname%/

    to

    %postname% (i.e without the slashes)

    and it worked for me.

    Good luck.

    Mr Bingo

  22. sijith
    Member
    Posted 6 years ago #

    waw..great...

    It worked for me as well. I too had the same above issue regarding the .htaccess.
    What I did was, I put the below configuration to .htaccess file.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /dreams/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /dreams/index.php [L]
    </IfModule>

    and then, during setting the perm link option, I choose the custom structure and gave /index.php/%postname% .

    and it worked like a charm.

    you can see the website here, http://www.libisoft.com/dreams

    Sijith

  23. inkywillow
    Member
    Posted 6 years ago #

    I have been pulling my hair out over this all morning. I just went to try Sellhigh's idea of cutting out that final %/ from my custom structure when I noticed a single space at the end of the permalink string, just after the final percent sign (I didn't have the slash there anyway) I deleted that and hey presto! All working again. It now reads /%category%/%post_id%

    Check for that space folks!

    Tom

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.